HDOJ Watch The Movie

Watch The Movie

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 65535/65535K (Java/Other)
Total Submission(s) : 11   Accepted Submission(s) : 2
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

New semester is coming, and DuoDuo has to go to school tomorrow. She decides to have fun tonight and will be very busy after tonight. She like watch cartoon very much. So she wants her uncle to buy some movies and watch with her tonight. Her grandfather gave them L minutes to watch the cartoon. After that they have to go to sleep.
DuoDuo list N piece of movies from 1 to N. All of them are her favorite, and she wants her uncle buy for her. She give a value Vi (Vi > 0) of the N piece of movies. The higher value a movie gets shows that DuoDuo likes it more. Each movie has a time Ti to play over. If a movie DuoDuo choice to watch she won’t stop until it goes to end.
But there is a strange problem, the shop just sell M piece of movies (not less or more then), It is difficult for her uncle to make the decision. How to select M piece of movies from N piece of DVDs that DuoDuo want to get the highest value and the time they cost not more then L.
How clever you are! Please help DuoDuo’s uncle.

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by input data for each test case:
The first line is: N(N <= 100),M(M<=N),L(L <= 1000)
N: the number of DVD that DuoDuo want buy.
M: the number of DVD that the shop can sale.
L: the longest time that her grandfather allowed to watch.
The second line to N+1 line, each line contain two numbers. The first number is the time of the ith DVD, and the second number is the value of ith DVD that DuoDuo rated.

Output

Contain one number. (It is less then 2^31.)
The total value that DuoDuo can get tonight.
If DuoDuo can’t watch all of the movies that her uncle had bought for her, please output 0.

Sample Input

1
3 2 10
11 100
1 2
9 1

Sample Output

3

Source

2010 ACM-ICPC Multi-University Training Contest(6)——Host by BIT
 

//从N章碟片中选出M张,使得在总时间不超过L的范围达到价值最大
//每张碟片给出播放时间和价值,典型的背包问题。
//把每张碟片所需的时间看做体积,L为背包总体积
//二维背包,状态方程为 bag[i][j]=max(bag[i][j],bag[i-1][j-spend_time[k]]+value[k] )
#include<iostream>
#include<cstring>
using namespace std;
int value[101],spend_time[101],bag[101][1001];
int main(){
    int t,N,M,L;
    scanf("%d",&t);
    while(t--){
           memset(bag,-1,sizeof(bag));
           bag[0][0]=0; //有必要这样初始化,才能保证DuoDuo在不能看M张碟片时输出0
           scanf("%d%d%d",&N,&M,&L);
           for(int i=1;i<=N;i++)
                scanf("%d%d",&spend_time[i],&value[i]);
           for(int i=1;i<=N;i++)
               for(int j=L;j>=spend_time[i];j--)
                     for(int k=M;k>=1;k--)  //必须保证恰好是M张碟片,这里也可写成升序(或许这样更容易理解)
                          if(bag[k-1][j-spend_time[i]]>=0) //不能省略
                                bag[k][j]=max(bag[k][j],bag[k-1][j-spend_time[i]]+value[i]);    
          int ans=0;
          for(int i=0;i<=L;i++)
                ans=max(ans,bag[M][i]);
          printf("%d\n",ans);
    }
    //system("pause");
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值