UVA 10341 Solve It

Problem F
Solve It
Input: standard input
Output: standard output
Time Limit: 1 second
Memory Limit: 32 MB
Solve the equation:
p*e-x + q*sin(x) + r*cos(x) + s*tan(x) + t*x2 + u = 0
where 0 <= x <= 1.
Input
Input consists of multiple test cases and terminated by an EOF. Each test case consists of
6 integers in a single line: p, q, r, s, t and u (where 0 <= p,r <= 20 and -20 <=
q,s,t <= 0). There will be maximum 2100 lines in the input file.
Output
For each set of input, there should be a line containing the value of x, correct upto 4
decimal places, or the string "No solution", whichever is applicable.
Sample Input
0 0 0 0 -2 1
1 0 0 0 -1 2
1 -1 1 -1 -1 1
Sample Output
0.7071
No solution
0.7554

首先对函数求导,发现是一个递减函数,这样就可以用二分求答案了,不过这个题精度要求好高啊,必须到10^-8次啊,一开始弄了一个10^-6,结果WA了,看来很久没有感觉有错误,就改了一下8就通过了,晕啊!

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;

const double esp=1e-8;

double p,q,r,s,t,u;

double get_value(double x)
{
    return p*exp(-x)+q*sin(x)+r*cos(x)+s*tan(x)+t*x*x+u;
}

double find(double x,double y)
{
    while (y-x>esp)
    {
        double m=x+(y-x)/2;
        if (get_value(m)-esp>0) x=m;
        else y=m;
    }
    return x;
}

int main()
{
    while (scanf("%lf%lf%lf%lf%lf%lf",&p,&q,&r,&s,&t,&u)!=EOF)
    {
        if (get_value(0.0)<0 || get_value(1.0)>0)
        printf("No solution\n");
        else
        printf("%.4lf\n",find(0.0,1.0));
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/chensunrise/p/3694254.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值