Dungeon Master

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form

Escaped in x minute(s).


where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line

Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

这是一道广搜题,我搜索学的不是很扎实,所以这道题可能讲解的不是那么优秀,这是一个三维逃生的问题,先把终点和起点的三维坐标记录下来,然后从起点按照上下左右前后这六个方向进行搜索,最后看是否能到达终点,以及到达终点需要的时间。

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
char a[101][101][101];
int book[101][101][101];
int s[6][3]={{0,0,1},{0,0,-1},{0,1,0},{0,-1,0},{1,0,0},{-1,0,0}};
int l,r,c,starx,stary,starz,endx,endy,endz;
struct node
{
    int x,y,z,t;
};
int cn()
{
    queue<node>Q;
    node st,en;
    st.x=starx;
    st.y=stary;
    st.z=starz;
    st.t=0;
    book[st.x][st.y][st.z]=1;
    Q.push(st);
    while(!Q.empty())
    {
        st=Q.front();
        Q.pop();
        if(st.x==endx&&st.y==endy&&st.z==endz)
            return st.t;
        for(int i=0;i<6;i++)
        {
            en.x=st.x+s[i][0];
            en.y=st.y+s[i][1];
            en.z=st.z+s[i][2];
            en.t=st.t+1;
            if(!book[en.x][en.y][en.z]&&en.x>=0&&en.x<l&&en.y>=0&&en.y<r&&en.z>=0&&en.z<c&&a[en.x][en.y][en.z]!='#')
            {
                book[en.x][en.y][en.z]=1;
                Q.push(en);
            }
        }
    }
    return -1;
}
int main()
{
    while (~scanf("%d%d%d",&l,&r,&c)&&l&&r&&c)
    {
        memset(book,0,sizeof(book));
        for (int i=0;i<l;i++)
        {
            for (int j=0;j<r;j++)
            {
                getchar();
                for (int k=0;k<c;k++)
                {
                    scanf("%c",&a[i][j][k]);
                    if(a[i][j][k]=='S')
                    {
                        starx=i;
                        stary=j;
                        starz=k;
                    }
                    else if(a[i][j][k]=='E')
                    {
                        endx=i;
                        endy=j;
                        endz=k;
                    }
                }
            }
            getchar();
        }
        int sum=cn();
        if(sum==-1)
        printf("Trapped!\n");
        else
        printf("Escaped in %d minute(s).\n",sum);
    }
    return 0;
}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值