数据结构实验之查找三:树的种类统计

数据结构实验之查找三:树的种类统计

Time Limit: 400MS Memory Limit: 65536KB
Problem Description

随着卫星成像技术的应用,自然资源研究机构可以识别每一个棵树的种类。请编写程序帮助研究人员统计每种树的数量,计算每种树占总数的百分比。

Input

输入一组测试数据。数据的第1行给出一个正整数N (n <= 100000),N表示树的数量;随后N行,每行给出卫星观测到的一棵树的种类名称,树的名称是一个不超过20个字符的字符串,字符串由英文字母和空格组成,不区分大小写。

Output

按字典序输出各种树的种类名称和它占的百分比,中间以空格间隔,小数点后保留两位小数。

Example Input
2
This is an Appletree
this is an appletree
Example Output
this is an appletree 100.00%
# include<stdio.h>
# include<cstring>
# include<cstdlib>
using namespace std;
struct node
{
    int data;
    char str[1100];
    struct node *l, *r;
};
int l;
void creat(struct node *&root, char str1[])//注意
{
    if(!root)
    {
        root=(struct node *)malloc(sizeof(struct node));
        strcpy(root->str, str1);
        root->data=1;
        root->l=NULL;
        root->r=NULL;
    }
    else
    {
        int x=strcmp(root->str, str1);
        if(x>0)
        {
            creat(root->l, str1);
        }
        else if(x<0)
            {
                creat(root->r, str1);
            }
        else
            root->data++;
    }
}
void show(struct node *root)
{
    if(root)
    {
       show(root->l);
       printf("%s %.2lf%%\n", root->str, 100.0*root->data/l);
       show(root->r);
    }
}
int main()
{
    int t, i, n;
    char str1[1100];
    struct node *root=NULL;
    scanf("%d", &t);
    getchar();
    l=t;
    while(t--)
    {
        gets(str1);
        n=strlen(str1);
        for(i=0; i<n; i++)
        {
            if(str1[i]>='A'&&str1[i]<='Z')
                str1[i] += 'a'-'A';
        }
        creat(root, str1);
    }
    show(root);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值