201771010129 王颖奇 第三周 Java基本程序设计总结

 

实验三 Java基本程序设计

实验时间 2018-9-13

201771010129 王颖奇

1、实验目的与要求

(1)进一步掌握Eclipse集成开发环境下java程序开发基本步骤;

(2)熟悉PTA平台线上测试环境;

(3)掌握Java语言构造基本程序语法知识(ch1-ch3);

(4)利用已掌握Java语言基本程序设计知识,学习设计开发含有一个主类、类内可有多个方法的应用程序。

2、实验内容和步骤

实验1:采用个人账号登录https://pintia.cn/,使用邀请码588329加入PTA平台NWNU-2017NISE教学班(西北师范大学 计算机科学与工程学院 2017级 网络与信息安全),完成《2018秋季西北师范大学面向对象程序设计(Java)(ch1-ch3)测试题1》,测试时间120分钟;

成绩:

实验2-实验3在课后完成

实验2公民身份证号码按照GB11643—1999《公民身份证号码》国家标准编制,由18位数字组成:前6位为行政区划分代码,第7位至14位为出生日期码,第15位至17位为顺序码,第18位为校验码。从键盘输入1个身份证号,将身份证号的年月日抽取出来,按年-月-日格式输出。注意:输入使用Scanner类的nextLine()方法,以免出错。

输入样例:

34080019810819327X

输出样例:

1981-08-19

代码:

package shen;

import java.util.Scanner;

public class shen {

public static void main(String[] args) {

Scanner sc = new Scanner(System.in);

System.out.println("请输入正确的18位身份证号码");

String num = sc.nextLine();

int i = 6;

String year = num.substring(i, i+4);

String yue = num.substring(i+4, i+6);

String ri = num.substring(i+6, i+8);

System.out.println(year+"-"+yue+"-"+ri);

}

}

尾数为数字的身份证号:

尾数为字母的身份证号:

实验3:studentfile.txt文件内容是本班同学的学号与姓名,利用此文件编制一个程序,将studentfile.txt文件的信息读入到内存,并提供两类查询功能:

(1)输入姓名查询学号;

(2)输入学号查询姓名。要求程序具有友好人机交互界面。

编程建议:

(1)从文件中读入学生信息,可以编写如下函数:

public static void StudentsFromFile(String fileName))

(2)输入姓名查找学生学号,可以编写如下函数:

public static String findStudent(String name)

(3)输入学号查找学生姓名,可以编写如下函数:

public static String findStudent(String ID)

代码:

package cha;

import java.io.BufferedReader;

public class Test {

 

    private static ArrayList<Student> studentList = null;

 

    public static void StudentsFromFile(String fileName){

        File file = new File(fileName);

        BufferedReader reader = null;

        try {

            reader = new BufferedReader(new FileReader(file));

            String tempString = null;

            while ((tempString = reader.readLine()) != null) {

                String str[] = tempString.split(" ");

                if(studentList != null && str.length > 1) {

                    Student student = new Student();

                    student.setStudentId(str[0]);

                    student.setName(str[1]);

                    studentList.add(student);

                }

            }

            reader.close();

        } catch (IOException e) {

            e.printStackTrace();

        } finally {

            if (reader != null) {

                try {

                    reader.close();

                } catch (IOException e1) {

                }

            }

        }

    }

 

    public static String findStudentIdByName(String name) {

        String studentId = null;

        for(Student student : studentList) {

            if(student.getName().equals(name)) {

                studentId = student.getStudentId();

                break;

            }

        }

        return studentId;

    }

    public static String findStudentNameById(String ID) {

        String studentName = null;

        for(Student student : studentList) {

            if(student.getStudentId().equals(ID)) {

                studentName = student.getName();

                break;

            }

        }

        return studentName;

    }

    public static void main(String args[]) {

        String path = "C:\\Users\\ASUS\\Desktop\\java\\实验三\\studentfile.txt";

        studentList = new ArrayList<Student>();

        StudentsFromFile(path);

        int statu = 1;

        System.out.println();

        while(statu != 0) {

            System.out.println("1:Select StudentId By StudentName");

            System.out.println("2:Select StudentName by StudentId");

            System.out.println("0:exit");

            Scanner scanner = new Scanner(System.in);

            statu = scanner.nextInt();

            switch(statu) {

                case 1:{

                    System.out.println("Please input student name:");

                    Scanner scanner1 = new Scanner(System.in);

                    String name = scanner1.nextLine();

                    String Id = findStudentIdByName(name);

                    if(Id != null) {

                        System.out.println("Name: "+name+" Id: "+Id);

                    }else {

                        System.out.println("Don`t has this student");

                    }

 

                }break;

                case 2:{

                    System.out.println("Please input student Id:");

                    Scanner scanner2 = new Scanner(System.in);

                    String Id = scanner2.nextLine();

                    String name = findStudentNameById(Id);

                    if(name != null) {

                        System.out.println("name: "+name+" Id: "+Id);

                    }else {

                        System.out.println("Don`t has this student");

                    }

                }break;

                case 0:

                    statu = 0; break;

                default:

                    System.out.println("input error");

            }

        }

        System.out.println("byebye!");

    }

}

因为使用了ArrayList<Student> studentList,所以需要新建一个student类

package cha;

public class Student {

    private String name;

    private String studentId;

 

    public Student(String name, String studentId) {

        this.name = name;

        this.studentId = studentId;

    }

 

    public String getName() {

        return name;

    }

 

    public void setName(String name) {

        this.name = name;

    }

 

    public String getStudentId() {

        return studentId;

    }

 

    public void setStudentId(String studentId) {

        this.studentId = studentId;

    }

 

    public Student() {

    }

}

结果:

总结:

    通过前三章的测试,我了解到了自己在java程序编写方面的不足,需要在课余时间多下功夫学习。另外,通过实验2中,我学会了使用Scanner类的nextLine()方法(碰到回车就会结束)编写输入字符串的程序;在编写实验3的过程中,我学会了使用student类的方法存放学生数据并编写程序。

转载于:https://www.cnblogs.com/1556889081wyq/p/9655891.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
【优质项目推荐】 1、项目代码均经过严格本地测试,运行OK,确保功能稳定后才上传平台。可放心下载并立即投入使用,若遇到任何使用问题,随时欢迎私信反馈与沟通,博主会第一时间回复。 2、项目适用于计算机相关专业(如计科、信息安全、数据科学、人工智能、通信、物联网、自动化、电子信息等)的在校学生、专业教师,或企业员工,小白入门等都适用。 3、该项目不仅具有很高的学习借鉴价值,对于初学者来说,也是入门进阶的绝佳选择;当然也可以直接用于 毕设、课设、期末大作业或项目初期立项演示等。 3、开放创新:如果您有一定基础,且热爱探索钻研,可以在此代码基础上二次开发,进行修改、扩展,创造出属于自己的独特应用。 欢迎下载使用优质资源!欢迎借鉴使用,并欢迎学习交流,共同探索编程的无穷魅力! 基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip 基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip 基于业务逻辑生成特征变量python实现源码+数据集+超详细注释.zip
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值