1878: [SDOI2009]HH的项链
Time Limit: 4 Sec Memory Limit: 64 MB
Description
HH有一串由各种漂亮的贝壳组成的项链。HH相信不同的贝壳会带来好运,所以每次散步 完后,他都会随意取出一段贝壳,思考它们所表达的含义。HH不断地收集新的贝壳,因此他的项链变得越来越长。有一天,他突然提出了一个问题:某一段贝壳中,包含了多少种不同的贝壳?这个问题很难回答。。。因为项链实在是太长了。于是,他只好求助睿智的你,来解决这个问题。
Input
第一行:一个整数N,表示项链的长度。
第二行:N个整数,表示依次表示项链中贝壳的编号(编号为0到1000000之间的整数)。
第三行:一个整数M,表示HH询问的个数。
接下来M行:每行两个整数,L和R(1 ≤ L ≤ R ≤ N),表示询问的区间。
N ≤ 50000,M ≤ 200000。
Output
M行,每行一个整数,依次表示询问对应的答案。
Sample Input
6
1 2 3 4 3 5
3
1 2
3 5
2 6
Sample Output
2
2
4
题解
这题经典的莫队题,也是一道模板题,虽然不是最优秀的,本蒟蒻只会写莫队。
代码如下:
#include<cmath>
#include<cstdio>
#include<algorithm>
using namespace std;
int n,m,a[50005],K,num[1000005],Now,hsh[50005],ans;
struct xcw{int L,R,id,ans;}X[200005];
int cmp(xcw x,xcw y){return ((x.L/K)==(y.L/K))?x.R<y.R:x.L<y.L;}
int cmpid(xcw x,xcw y){return x.id<y.id;}
void Add(int x){if(!hsh[x]) ans++;hsh[x]++;}
void Del(int x){hsh[x]--;if(!hsh[x]) ans--;}
int main(){
scanf("%d",&n);K=sqrt(n);
for(int i=1;i<=n;i++){
scanf("%d",&a[i]);
if(!num[a[i]]) num[a[i]]=++Now;
a[i]=num[a[i]];
}
scanf("%d",&m);
for(int i=1;i<=m;i++) scanf("%d%d",&X[i].L,&X[i].R),X[i].id=i;
sort(X+1,X+1+m,cmp);
int Lt=1,Rt=0;
for(int i=1;i<=m;i++){
while(Lt<X[i].L) Del(a[Lt++]);
while(Lt>X[i].L) Add(a[--Lt]);
while(Rt<X[i].R) Add(a[++Rt]);
while(Rt>X[i].R) Del(a[Rt--]);
X[i].ans=ans;
}
sort(X+1,X+1+m,cmpid);
for(int i=1;i<=m;i++) printf("%d\n",X[i].ans);
return 0;
}