Fence Repair STL——优先队列

题目描述:

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the Nplanks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

输入:

Line 1: One integer N, the number of planks 
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

输出:

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

样例:

Sample Input

3
8
5
8

Sample Output

34
注释:
He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8.
The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5
instead, the second cut would cost 16 for a total of 37 (which is more than 34).
题目大意:
农夫需要N段长度分别为L1,L2...的木板,但他只有一段长度为所需木板总长度的木板,他找到农夫Don帮他锯开,每锯一次就按被锯的木板长度收一次费,求农夫的最小花费。
代码:
#include<iostream>
#include<stdio.h>
#include<queue>
using namespace std;
priority_queue<long long int,vector<long long int>,greater<long long int> > len;
int main(){
    long long int num,temp;
    scanf("%lld",&num);
    for(int i=0;i<num;++i){
        scanf("%lld",&temp);
        len.push(temp);
    }
    num=0;
    while(1){
        temp=len.top();
        len.pop();
        if(len.empty()) break;
        temp+=len.top();
        len.pop();
        len.push(temp);
        num+=temp;
    }
    printf("%lld",num);
    return 0;
}

这道题目用到了优先队列

priority_queue

声明:

priority_queue<Type, Container, Functional>

其中Type 为数据类型,Container为保存数据的容器,Functional 为元素比较方式

目前还是有点迷惑,感觉container是存放队列的容器,然后functional就是类似于sort函数中的cmp的作用。

 

本题中定义的优先队列和普通队列不一样的就是,将入队的元素自动按从小到大的顺序排序,队顶为队列中最小的元素,将所需的木板长度入队,每次从队首取出最短的两块木板合成为更长的木板,这样就可以保证每次切割木板都是最小的情况,再将每次合成后的木板长度累加,即得答案。

关于优先队列的一些博文启发:

https://www.cnblogs.com/Deribs4/p/5657746.html

https://www.cnblogs.com/xzxl/p/7266404.html

转载于:https://www.cnblogs.com/-y-i-/p/10333746.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值