简单二分 UVA 10341

Solve the equation:
        p*e-x q*sin(x) + r*cos(x) + s*tan(x) + t*x2 + u = 0
        where 0 <= x <= 1.

Input

Input consists of multiple test cases and terminated by an EOF. Each test case consists of 6 integers in a single line: pqrst and u(where 0 <= p,r <= 20 and -20 <= q,s,t <= 0). There will be maximum 2100 lines in the input file.

Output

For each set of input, there should be a line containing the value of x, correct upto 4 decimal places, or the string "No solution", whichever is applicable.

Sample Input

0 0 0 0 -2 1
1 0 0 0 -1 2
1 -1 1 -1 -1 1

Sample Output

0.7071
No solution
0.7554


这种解方程求解题,先考虑下二分,通过系数判定函数形势,是个递减的非线性方程,给出具体方程,要在[0,1]里找方程对应的x。
因为是取后四位,精度开到10e-5以上我觉得都是可以的,当然也要满足运行时间的要求。
因为是递减的,靠在0那边就大于0,靠1那边就小于0,用f*f的符号判断解的位置。

代码:

#include<bits/stdc++.h>
using namespace std;

double p,q,r,s,t,u;
double f(double x)
{
return p*exp(-x)+q*sin(x)+r*cos(x)+s*tan(x)+t*x*x+u;
}
int main()
{
double l,r,m;

while(~scanf("%lf%lf%lf%lf%lf%lf",&p,&q,&r,&s,&t,&u))
{
l=0;r=1;
if(f(l)*f(r)>0) {cout<<"No solution"<<endl; continue;}
while(r-l>10e-6)
{
m=(r+l)/2;
if(f(l)*f(m)>0)
l=m;
else r=m;
}
printf("%.4lf\n", m);
}
return 0;
}


转载于:https://www.cnblogs.com/liebecelery/p/7117588.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值