Solve It UVA 10341


Solve It

Input: standard input

Output: standard output

Time Limit: 1 second

Memory Limit: 32 MB

Solve the equation:
        p*e-xq*sin(x) + r*cos(x) + s*tan(x) + t*x2 + u = 0
        where 0 <= x <= 1.

Input

Input consists of multiple test cases and terminated by an EOF. Each test case consists of 6 integers in a single line: pqrst and u (where 0 <= p,r <= 20 and -20 <= q,s,t <= 0). There will be maximum 2100 lines in the input file.

Output

For each set of input, there should be a line containing the value of x, correct upto 4 decimal places, or the string "No solution", whichever is applicable.

Sample Input

0 0 0 0 -2 1
1 0 0 0 -1 2
1 -1 1 -1 -1 1

Sample Output

0.7071
No solution

0.7554

题解:函数单调性+二分查找

其实如果这个函数不单调,可以将这个函数分解成2个函数,只需要一个单调递增,一个单调递减,计算两个曲线是否相交。

ps:这里需要注意的是,题目中要求精度为小数点后四位,程序中二分查找时s与m的精度为 eps=1e-9;尽量将精度增大,如果这时候设定的是 eps=1e-6,结果会是wrong answer.由于double的数值不是连续的,所以尽量把数值精度取大一些,2*要求的精度。

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;
const double eps=1e-9;
double p,q,r,s,t,u;
double f(double x){
    double res;
    res=p*exp(-1*x)+q*sin(x)+r*cos(x)+s*tan(x)+t*x*x+u;
    return res;
}
void solve(){
    double rs=f(0);
    double re=f(1);
    if(rs*re>0){
        printf("No solution\n");
    }else{
        double s,e,m,ans;
        s=0;e=1;
        while(e-s>eps){
            m=(s+e)/2;
            ans=f(m);
            if(ans<0) e=m;
            else s=m;
        }
        printf("%.4lf\n",m);
    }
}
int main(){
    while(~scanf("%lf%lf%lf%lf%lf%lf",&p,&q,&r,&s,&t,&u)){
        solve();
    }
    return 0;
}

通过看网上的题解,学习了一种新的判断输入文件结束符的方式,利用位运算
~scanf("%lf%lf%lf%lf%lf%lf",&p,&q,&r,&s,&t,&u),这是因为输入文件结束符返回-1,而用2的补码存储时,-1的二进制表示为1111 1111 1111 1111 1111 1111 1111 1111 1111,全1,补码后为全0.

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值