[HDOJ1002] A + B Problem II 高数度加法运算

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

 

 
//4823648 2011-10-25 22:51:21 Accepted 1002 0MS 612K 1151 B C++ ajioy 
#include <iostream>
using namespace std;
#define MAXLEN 1000
int main(){
	char s1[MAXLEN],s2[MAXLEN];
	int cases = 1,times;
	cin >> times; 
	while(times--){
		cin >> s1 >> s2;
		int i;
	  int len1 = strlen(s1);
	  int len2 = strlen(s2);
	  int len = len1 >= len2 ? len1 : len2;
	  int *t1 = new int[(len + 1) * sizeof(int)];
	  int *t2 = new int[(len + 1) * sizeof(int)];
	  for(i = 0; i < len1; ++i) //把字符串转成整型数组,并反向以便运算 
	   t1[i] = s1[len1 - i - 1] - '0';
	   
	   	  for(i = 0; i < len2; ++i)
	   t2[i] = s2[len2 - i - 1] - '0';
	   
	  for(i = len1; i < len + 1; ++i) t1[i] = 0; //最高位补0 ,与大数保持一致 
	  for(i = len2; i < len + 1; ++i) t2[i] = 0;
	  
	  for(i = 0; i < len; ++i) //普通相加 
	   t1[i] += t2[i];
	   
	   while(t1[len - 1] == 0 && len > 1) len--;//清除左边为0 的元素 
	   for(i = 0; i < len; ++i)
	   	if(t1[i] >= 10){  
	   	   t1[i + 1] = t1[i + 1] + t1[i] / 10; //进位处理 
			  t1[i] %= 10;	
	   }
	   	   	
	   	if(t1[i] != 0) //如果两数相加值超过较大数的位数 
	   	len = i + 1; //长度加1 
	   	cout << "Case " << cases << ":" << endl;
	   	cout << s1 << " + " << s2 << " = "; //注意,+,=两边都有空格 
	   	for(i = len - 1;i >=0 ;--i)
	   	cout << t1[i];
	   	cout << endl;
	   	if(times != 0) //最后一行没有空格 
	   	cout << endl; 
	   	cases++;
	}
	
	return 0;
}

 
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值