HDU 1312 Red and Black

hdu 1312 题目链接
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0

Sample Output

45
59
6
13

解题思路:

红与黑的问题,广搜模版题。读取字符串之后,遇到@之后开始进行搜索遇到.之后进行置换为@,统计@个数,输出个数。

#include <stdio.h>
#include <string.h>

typedef struct n{
	int x,y;
}bfs;
bfs que[500];

int main()
{
	int i,j,k;
	int x0,y0,tx,ty;
	int head,tail,n,m;
	int book[50][50];
	char map[50][50];
	int next[4][2]={{-1,0},{0,-1},{0,1},{1,0}};
	while(scanf("%d%d",&m,&n),n!=0||m!=0)
	{
		k=0;
		memset(map,0,sizeof(map));
		memset(book,0,sizeof(book));
		for(i=0;i<n;i++)
			scanf("%s",map[i]);
		for(i=0;i<n;i++)
			for(j=0;j<m;j++)
				if(map[i][j]=='@'){
					x0=i;
					y0=j;
					break;
				}
		head=1;
		tail=1;
		que[head].x=x0;
		que[head].y=y0;
		book[x0][y0]=1;
		tail++;
		while(head<tail){
			for(i=0;i<4;i++){
				tx=que[head].x+next[i][0];
				ty=que[head].y+next[i][1];
				if(tx<0||ty<0||tx>=n||ty>=m)
					continue;
				if(book[tx][ty]==0&&map[tx][ty]=='.'){
					map[tx][ty]='@';
					book[tx][ty]=1;
					que[tail].x=tx;
					que[tail].y=ty;
					tail++;
				}
			}
			head++;
		}
		for(i=0;i<n;i++)
			for(j=0;j<m;j++)
				if(map[i][j]=='@')
					k++;
		printf("%d\n",k);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值