ldconfig报错 :libstdc++.so.6.0.18-gdb.py不是一个elf文件

今天安装wxWidgets,输入ldconfig竟然提示

/usr/lib64/libstdc++.so.6.0.18-gdb.py 不是一个elf文件,开头魔数错误

摸不着头脑,上网搜了一下,有说是gnu自己的错误,不过解决方法倒也简单,直接删除该文件

sudo rm /usr/lib64/libstdc++.so.6.0.18-gdb.py

再次ldconfig

整个世界清静了

未明白什么原因导致错误,但是后续安装其他东东都运行正常


两个参考链接:

http://blog.csdn.net/deltatang/article/details/8455473

http://ericjmritz.name/2013/08/24/ldconfig-usrliblibstdc-so-6-0-18-gdb-py-error/

©️2020 CSDN 皮肤主题: 编程工作室 设计师: CSDN官方博客 返回首页
实付0元
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值