杭电1025(最长上升子序列+二分查找优化)

Constructing Roads In JGShining’s Kingdom(难度:1)

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

JGShining’s kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they’re unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don’t wanna build a road with other poor ones, and rich ones also can’t abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich cities marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities … And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.
这里写图片描述
In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^

Input

Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.

Output

For each test case, output the result in the form of sample.
You should tell JGShining what’s the maximal number of road(s) can be built.

Sample Input

2
1 2
2 1
3
1 2
2 3
3 1

Sample Output

Case 1:
My king, at most 1 road can be built.

Case 2:
My king, at most 2 roads can be built.

思路:

题意:

  • 贫穷的城市只缺一种资源,富裕的城市只盛产一种资源;
  • 贫穷的城市和富裕的城市分别在两条平行线上;
  • 贫穷的城市在线1,富裕的城市在线2,线1在线2上面;
  • 城市编号均为从左至右依次增大;
  • 在贫穷的城市和富裕的城市间修路,但上图所示的修路方法是不合法的。

方法:最长上升子序列

注意:

  • 英语单词的复数;
  • 时间复杂度为O(n*n),会超时,所以优化为时间复杂度为O(nlogn)的最长上升子序列。

AC代码:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

#define maxn 500010

int dp[maxn];//上升子序列中最后一个的编号 
int city[maxn];//poor对应的rich城市 

//二分查找优化最长上升子序列 
int binarysearch(int num,int n)
{
    int left=1;
    int right=n;
    int mid;
    while(left<=right)
    {
        mid=(left+right)/2;
        if(dp[mid]==num) return mid;
        else if(dp[mid]>num) right=mid-1;
        else left=mid+1;
    }
    return left;
}

int main()
{
    int n,p,r,j,len,icase=0;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&p,&r);
            city[p]=r;//第p个poor对应第r个rich 
        }
        memset(dp,0,sizeof(dp));
        dp[1]=city[1]; //将第一组数插入 
        len=1;//长度为1 
        for(int i=2;i<=n;i++)
        {
            j=binarysearch(city[i],len);//查找剩下的poor对应的rich 
            dp[j]=city[i];
            if(len<j) len=j;//更新长度 
        }
        printf("Case %d:\n",++icase);
        if(len==1) printf("My king, at most %d road can be built.\n",len);
        else printf("My king, at most %d roads can be built.\n",len);
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值