POJ 3259 Wormholes(负权判断)

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 56618 Accepted: 21131

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
路是双向的,虫洞是单向的,只要存在负环,则一定满足条件。
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string.h>
#include<string>
#include<vector>
const int INF=0x3f3f3f3f;
int N,M,W,d[502];
using namespace std;
struct node 
{
	int to,cost;
};
vector<node> rode[502];
void init()
{
	for(int i=0;i<=500;i++)
		d[i]=INF;
	d[1]=0;
}
bool Bell()
{
	bool bb;
	for(int i=0;i<N;i++)
	{
		bb=0;
		for(int j=1;j<=N;j++)
		{
			int L=rode[j].size();
			for(int k=0;k<L;k++)
			{
				node e=rode[j][k];
				if(d[e.to]>d[j]+e.cost)
				{
					d[e.to]=d[j]+e.cost;
					bb=1;
				}
			}
		}
		if(bb==0)return 0;
	}
	return 1;
}
int main()
{
	int T,i,j,k;scanf("%d",&T);
	while(T--)
	{
		init();
		scanf("%d%d%d",&N,&M,&W);
		for(i=1;i<=M+W;i++)
		{
			int x,y,z;scanf("%d%d%d",&x,&y,&z);
			if(i<=M)
			{
				node r;r.to=y,r.cost=z;
				rode[x].push_back(r);r.to=x;
				rode[y].push_back(r);//双向路
			}
			else
			{
				node r;r.to=y,r.cost=-z;
				rode[x].push_back(r);//单向虫洞
			}
		}
		if(Bell())printf("YES\n");
		else printf("NO\n");
		for(i=0;i<=N;i++)
			rode[i].clear();//一定记得清空,wa了好几次
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值