POJ 1201 Intervals(差分约束系统)

Intervals
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions:28274 Accepted: 10899

Description

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn. 
Write a program that: 
reads the number of intervals, their end points and integers c1, ..., cn from the standard input, 
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n, 
writes the answer to the standard output. 

Input

The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output

6
因为T[b[i]]-T[a[i]]>=c[i]-1;0<=T[i+1]-T[i]<=1;
因此得T[b[i]-1]-T[a[i]]>=c[i];T[i+1]-T[i]>=0;T[i]-T[i+1]>=-1;
#include<cstdio>
#include<queue>
#include<iostream>
#include<algorithm>
#include<string.h>
const int INF = 0x3f3f3f3f;
int d[50003], head[50003], tol,ma,mi;
bool vis[50003];
using namespace std;
struct EDGE
{
	int to, cost, next;
}edge[151000];//注意要连3*n条边,数组不要开小
void init()
{
	memset(vis, 0, sizeof(vis));
	for (int i = 0; i <= 50002; i++)
		d[i] = -INF;
	for (int i = 0; i <= 50002; i++)
		head[i] = -1;
	ma = -INF; mi = INF;//求mi到ma的最大距离
}
void add(int a, int b, int c)
{
	edge[tol].to = b;
	edge[tol].cost = c;
	edge[tol].next = head[a];
	head[a] = tol++;
}
void spfa()
{
	queue<int> P; P.push(mi); vis[mi] = 1;
	while (!P.empty())
	{
		int t = P.front(); P.pop(); vis[t] = 0;
		for (int i = head[t]; i != -1; i = edge[i].next)
		{
			EDGE e = edge[i];
			if (d[e.to]<d[t] + e.cost)
			{
				d[e.to] = d[t] + e.cost;
				int y = d[e.to];
				if (!vis[e.to])
				{
					vis[e.to] = 1;
					P.push(e.to);
				}
			}
		}
	}
}
int main()
{
	init();
	int n; scanf("%d", &n);
	tol = 0;
	int i, j, k;
	for (i = 1; i <= n; i++)
	{
		int x, y, z; scanf("%d%d%d", &x, &y, &z);
		add(x, y+1, z);
		mi = min(mi, x);
		ma = max(ma, y+1);
	}
	for (i = mi; i<ma; i++)
		add(i, i + 1, 0);
	for (i = mi; i<ma; i++)
		add(i + 1, i, -1);
	d[mi] = 0;
	spfa();
	printf("%d", d[ma]);
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值