POJ 3616 Milking Time

Milking Time
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions:11405 Accepted: 4824

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43
这题开始用迪杰斯特拉求了个最短路,结果超时啦,因为m1000之内,所以这里可以动态规划
#include<iostream>
#include<cstdio>
#include<string.h>
#include<cmath>
#include<algorithm>
int dp[1100000];
using namespace std;
struct node
{
    int start,end1;
    int cost;
}g[1002];
bool cmp(node a,node b)
{
    return a.end1<b.end1;
}
int main()
{
    memset(dp,0,sizeof(dp));
    int n,m,r;scanf("%d%d%d",&n,&m,&r);
    int i,j;
    for(i=1;i<=m;i++)
    {
        scanf("%d%d%d",&g[i].start,&g[i].end1,&g[i].cost);
        g[i].end1+=r;
    }
    sort(g+1,g+m+1,cmp);//按结束的时间从小到大排序
    int t=1;
    for(i=0;i<=n+r;i++)
    {
        node e=g[t];
        if(i==e.end1)
        {
            dp[i]=max(dp[i],dp[i-1]);
            dp[i]=max(dp[e.start]+e.cost,dp[i]);//若采用该时间段
            //则剩余时间最大产量dp[e.start]
            t++;
            if(t<=m&&g[t].end1==g[t-1].end1)i--;//若存在结束时间相同的情况
            //则在进行一次判断。
        }
        else if(i!=0)dp[i]=dp[i-1];
    }
    printf("%d",dp[n+r]);
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值