UVA 1151 Buy or Build (Kruskal+二进制枚举子集)

问题 L: Buy or Build

时间限制: 20 Sec   内存限制: 128 MB
提交: 6   解决: 4
[ 提交][ 状态][ 讨论版]

题目描述

World Wide Networks (WWN) is a leading company that operates large telecommunication networks. WWN would like to setup a new network in Borduria, a nice country that recently managed to get rid of its military dictator Kurvi-Tasch and which is now seeking for investments of international companies (for a complete description of Borduria, have a look to the following Tintin albums ``King Ottokar's Sceptre", ``The Calculus Affair" and ``Tintin and the Picaros"). You are requested to help WWN todecide how to setup its network for a minimal total cost. 
Problem 
There are several local companies running small networks (called subnetworks in the following) that partially cover the n largest cities of Borduria. WWN would like to setup a network that connects all n cities. To achieve this, it can either build edges between cities from scratch or it can buy one or several subnetworks from local companies. You are requested to help WWN to decide how to setup its network for a minimal total cost. 

  • All n cities are located by their two-dimensional Cartesian coordinates. 
  • There are q existing subnetworks. If q>=1 then each subnetwork c ( 1<=c<=q ) is defined by a set of interconnected cities (the exact shape of a subnetwork is not relevant to our problem). 
  • A subnetwork c can be bought for a total cost wc and it cannot be split (i.e., the network cannot be fractioned). 
  • To connect two cities that are not connected through the subnetworks bought, WWN has to build an edge whose cost is exactly the square of the Euclidean distance between the cities.


You have to decide which existing networks you buy and which edges you setup so that the total cost is minimal. Note that the number of existing networks is always very small (typically smaller than 8). 
A 115 Cities Instance 
Consider a 115 cities instance of the problem with 4 subnetworks (the 4 first graphs in Figure 1). As mentioned earlier the exact shape of a subnetwork is not relevant still, to keep figures easy to read, we have assumed an arbitrary tree like structure for each subnetworks. The bottom network in Figure 1 corresponds to the solution in which the first and the third networks have been bought. Thin edges correspond to edges build from scratch while thick edges are those from one of the initial networks. 

输入

The first line contains the number n of cities in the country ( 1<=n<=1000 ) followed by the number q of existing subnetworks ( 0<=q<=8 ). Cities are identified by a unique integer value ranging from 1 to n . The first line is followed by q lines (one per subnetwork), all of them following the same pattern: The first integer is the number of cities in the subnetwork. The second integer is the the cost of the subnetwork (not greater than 2 x 106 ). The remaining integers on the line (as many as the number of cities in the subnetwork) are the identifiers of the cities in the subnetwork. The last part of the file contains n lines that provide the coordinates of the cities (city 1 on the first line, city 2 on the second one, etc). Each line is made of 2 integer values (ranging from 0 to 3000) corresponding to the integer coordinates of the city.

输出

Your program has to write the optimal total cost to interconnect all cities.

样例输入

7 3
2 4 1 2
3 3 3 6 7
3 9 2 4 5
0 2
4 0
2 0
4 2
1 3
0 5
4 4

样例输出

17

提示

Sample Explanation: The above instance is shown in Figure 2. An optimal solution is described in Figure 3 (thick edges come from an existing network while thin edges have been setup from scratch). 





Figure 3: An optimal solution of the 7 City instance in which which the first and second existing networkshave been bought while two extra edges (1, 5) and (2, 4) 


用二进制枚举每一种可能的情况
代码:

#include<bits/stdc++.h>
int n,q,cost[10],par[1002],rank1[1002],x[1002],y[1002],N;
using namespace std;
vector<int>g[10];
struct node
{
    int from,to,cost;
} rode[1000004];
bool cmp(node a,node b)
{
    return a.cost<b.cost;
}
void init()
{
    for(int i=0; i<=1000; i++)
        par[i]=i,rank1[i]=0;
}
int find(int x)
{
    if(x==par[x]) return x;
    return par[x]=find(par[x]);
}
bool same(int x,int y)
{
    return find(x)==find(y);
}
void unite(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x==y)return;
    if(rank1[x]<rank1[y])
        par[x]=y;
    else
    {
        par[y]=x;
        if(rank1[x]==rank1[y])
            rank1[x]++;
    }
}
int Kruskal()
{
    int ans=0;
    for(int i=0; i<N; i++)
    {
        node e=rode[i];
        if(!same(e.from,e.to))
        {
            ans+=e.cost;
            unite(e.from,e.to);
        }
    }
    return ans;
}
int meiju()
{
    init();
    int ans=Kruskal();
    int i,j;
    for(i=0; i<(1<<q); i++)
    {
        init();
        int ans2=0;
        for(j=0; j<q; j++)
        {
            if(i&(1<<j))
            {
                ans2+=cost[j];
                int L=g[j].size();
                for(int k=1; k<L; k++)
                {
                    unite(g[j][0],g[j][k]);
                }
            }
        }
        ans=min(ans,ans2+Kruskal());
    }
    return ans;
}
int main()
{
    while(~scanf("%d%d",&n,&q))
    {
        int i,j;N=0;
        for(i=0;i<q;i++)
        {
            int num;scanf("%d%d",&num,&cost[i]);
            for(j=0;j<num;j++)
            {
                int num1;scanf("%d",&num1);
                g[i].push_back(num1);
            }
        }
        for(i=1;i<=n;i++)
            scanf("%d%d",&x[i],&y[i]);
        for(i=1;i<=n;i++)
        {
            for(j=i+1;j<=n;j++)
            {
                rode[N].from=i;
                rode[N].to=j;
                rode[N++].cost=(x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]);
            }
        }
        sort(rode,rode+N,cmp);
        printf("%d\n",meiju());
        for(i=0;i<10;i++)g[i].clear();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值