HDU 1058 Humble Numbers

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28134    Accepted Submission(s): 12401


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
  
  
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
  
  
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
题意为寻找分解后因子只有2,3,5,或7的数,
因为题目只要求找前5842个,而第5842个为2000000000;
用每一种组合进行遍历,一旦大于2000000000则跳出,对
保存下来的数排序便是所求的序列。
补充序数词表示:
除去以11,12,13结尾的情况外,末尾数字凡是1,则st,
2,nd. 3,rd. else th.
若是以11,12,13结尾,也是th

#include<bits/stdc++.h>
using namespace std;
map<long long,int>mp;
long long pow1(long long a,long long b)
{
    long long r=1;
    while(b)
    {
        if(b%2==1)
            r=r*a;
        a=a*a;
        b=b/2;
    }
    return r;
}
int main()
{
    long long t[6003];
    memset(t,0,sizeof(t));
    long long i,j,k,h;int x=0;
    for(i=0; i<31; i++)
        for(j=0; j<20; j++)
            for(k=0; k<14; k++)
                for(h=0; h<12; h++)
                {
                    long long s=pow1(2,i)*pow1(3,j);
                    if(s>2000000000)break;
                    s=s*pow1(5,k);
                    if(s>2000000000)break;
                    s=s*pow1(7,h);
                    if(s>2000000000)break;
                    if(mp[s])continue;
                    mp[s]=1;
                    t[++x]=s;
                }
    sort(t+1,t+x+1);
    int n;
    while(~scanf("%d",&n))
    {
        if(!n)break;
        char s1,s2;
        if(n%10==1&&n%100!=11)s1='s',s2='t';
        else if(n%10==2&&n%100!=12)s1='n',s2='d';
        else if(n%10==3&&n%100!=13)s1='r',s2='d';
        else s1='t',s2='h';
        printf("The %d%c%c humble number is %lld.\n",n,s1,s2,t[n]);
    }
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值