ZOJ 4016 Mergeable Stack(栈的数组实现)

Mergeable Stack

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Given  initially empty stacks, there are three types of operations:

  • s v: Push the value  onto the top of the -th stack.

  • s: Pop the topmost value out of the -th stack, and print that value. If the -th stack is empty, pop nothing and print "EMPTY" (without quotes) instead.

  • s t: Move every element in the -th stack onto the top of the -th stack in order.

    Precisely speaking, denote the original size of the -th stack by , and the original size of the -th stack by . Denote the original elements in the -th stack from bottom to top by , and the original elements in the -th stack from bottom to top by .

    After this operation, the -th stack is emptied, and the elements in the -th stack from bottom to top becomes . Of course, if , this operation actually does nothing.

There are  operations in total. Please finish these operations in the input order and print the answer for every operation of the second type.

Input

There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:

The first line contains two integers  and  (), indicating the number of stacks and the number of operations.

The first integer of the following  lines will be  (), indicating the type of operation.

  • If , two integers  and  () follow, indicating an operation of the first type.
  • If , one integer  () follows, indicating an operation of the second type.
  • If , two integers  and  () follow, indicating an operation of the third type.

It's guaranteed that neither the sum of  nor the sum of  over all test cases will exceed .

Output

For each operation of the second type output one line, indicating the answer.

Sample Input
2
2 15
1 1 10
1 1 11
1 2 12
1 2 13
3 1 2
1 2 14
2 1
2 1
2 1
2 1
2 1
3 2 1
2 2
2 2
2 2
3 7
3 1 2
3 1 3
3 2 1
2 1
2 2
2 3
2 3
Sample Output
13
12
11
10
EMPTY
14
EMPTY
EMPTY
EMPTY
EMPTY
EMPTY
EMPTY

数组模拟栈的功能:

#include<bits/stdc++.h>
using namespace std;
const int maxn=300005;
int a[maxn],top[maxn],bottom[maxn],Next[maxn];
int cnt;
void Push(int s,int v)
{
    a[++cnt]=v;
    if(bottom[s]==0)
    {
        bottom[s]=cnt;
    }
    Next[cnt]=top[s];
    top[s]=cnt;
}
void Pop(int s)
{
    if(top[s]==0)printf("EMPTY\n");
    else
    {
        printf("%d\n",a[top[s]]);
        top[s]=Next[top[s]];
        if(top[s]==0)bottom[s]=0;
    }
}
void swapp(int s,int v)
{
    if(bottom[s]==0)bottom[s]=bottom[v];
    Next[bottom[v]]=top[s];
    top[s]=top[v];
    bottom[v]=top[v]=0;
}
int main()
{
    int T;scanf("%d",&T);
    while(T--)
    {
        memset(bottom,0,sizeof(bottom));
        memset(top,0,sizeof(top));
        memset(Next,0,sizeof(Next));
        int n,Q;scanf("%d%d",&n,&Q);
        cnt=0;
        while(Q--)
        {
            int op,x,y;scanf("%d",&op);
            if(op==1)
            {
                scanf("%d%d",&x,&y);
                Push(x,y);
            }
            else if(op==2)
            {
                scanf("%d",&x);
                Pop(x);
            }
            else
            {
                scanf("%d%d",&x,&y);
                if(bottom[y]==0)continue;
                swapp(x,y);
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值