SCU 4437 Carries

Carries

frog has nn integers a1,a2,,ana1,a2,…,an, and she wants to add them pairwise.

Unfortunately, frog is somehow afraid of carries (进位). She defines hardness h(x,y)h(x,y) for adding xx and yy the number of carries involved in the calculation. For example, h(1,9)=1,h(1,99)=2h(1,9)=1,h(1,99)=2.

Find the total hardness adding nn integers pairwise. In another word, find

1i<jnh(ai,aj)∑1≤i<j≤nh(ai,aj)
.

Input

The input consists of multiple tests. For each test:

The first line contains 11 integer nn (2n1052≤n≤105). The second line contains nn integers a1,a2,,ana1,a2,…,an. (0ai1090≤ai≤109).

Output

For each test, write 11 integer which denotes the total hardness.

Sample Input

    2
    5 5
    10
    0 1 2 3 4 5 6 7 8 9

Sample Output

    1
    20

题解:
判断两个数相加的第i位是否需要进位只需判断
x%(i^10)+y%(i^10)与i^10的关系即可。
若x%(i^10)+y%(i^10)>=i^10成立,则当z%(i^10)>=y%(i^10)时也一定成立
代码:

#include<bits/stdc++.h>
using namespace std;
#define ll long long
int a[100004],b[100004];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0; i<n; i++)scanf("%d",&a[i]);
        int mod=1;
        ll ans=0;
        for(int i=1; i<=9; i++)
        {
            mod*=10;
            for(int j=0; j<n; j++)b[j]=a[j]%mod;
            sort(b,b+n);
            for(int j=0; j<n; j++)
            {
                int pos=lower_bound(b+j+1,b+n,mod-b[j])-b;
                ans=ans+n-pos;
            }
        }
        printf("%lld\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值