POJ 2342 Anniversary party(树形dp)

Anniversary party
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10545 Accepted: 6033

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

#include<cstdio>
#include<string.h>
#include<algorithm>
#include<vector>
using namespace std;
const int maxn=6006;
vector<int>G[maxn];
int a[maxn],dp[maxn][2];//dp[i][0]表示i不来,dp[i][1]表示i来
bool is[maxn];
void dfs(int rt)
{
    dp[rt][0]=0;
    dp[rt][1]=a[rt];
    for(int i=0;i<G[rt].size();i++)
    {
        int to=G[rt][i];
        dfs(to);
        dp[rt][0]+=max(dp[to][0],dp[to][1]);//上司不来下属可来可不来
        dp[rt][1]+=dp[to][0];//上司来下属不来
    }
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(dp,0,sizeof(dp));
        memset(is,0,sizeof(is));
        for(int i=0;i<maxn;i++)
            G[i].clear();
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        while(1)
        {
            int x,y;scanf("%d%d",&x,&y);
            if(x==0&&y==0)break;
            G[y].push_back(x);
            is[x]=1;
        }
        for(int i=1;i<=n;i++)
        {
            if(!is[i])//根节点
            {
                dfs(i);
                printf("%d\n",max(dp[i][0],dp[i][1]));
                break;
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值