HDU 4276 The Ghost Blows Light(树形dp)

The Ghost Blows Light

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3844    Accepted Submission(s): 1256


Problem Description

My name is Hu Bayi, robing an ancient tomb in Tibet. The tomb consists of N rooms (numbered from 1 to N) which are connected by some roads (pass each road should cost some time). There is exactly one route between any two rooms, and each room contains some treasures. Now I am located at the 1st room and the exit is located at the Nth room. 
Suddenly, alert occurred! The tomb will topple down in T minutes, and I should reach exit room in T minutes. Human beings die in pursuit of wealth, and birds die in pursuit of food! Although it is life-threatening time, I also want to get treasure out as much as possible. Now I wonder the maximum number of treasures I can take out in T minutes.
 

Input
There are multiple test cases.
The first line contains two integer N and T. (1 <= n <= 100, 0 <= T <= 500)
Each of the next N - 1 lines contains three integers a, b, and t indicating there is a road between a and b which costs t minutes. (1<=a<=n, 1<=b<=n, a!=b, 0 <= t <= 100)
The last line contains N integers, which Ai indicating the number of treasure in the ith room. (0 <= Ai <= 100)
 

Output
For each test case, output an integer indicating the maximum number of treasures I can take out in T minutes; if I cannot get out of the tomb, please output "Human beings die in pursuit of wealth, and birds die in pursuit of food!".
 

Sample Input
 
 
5 10 1 2 2 2 3 2 2 5 3 3 4 3 1 2 3 4 5
 

Sample Output
 
 
11

题解:
从1到n最短路只有一条,因为这是一棵树。
这条最短路一定只走一次,如果要经过其他
的边,则必定经过两次。
代码:
#include<bits/stdc++.h>
using namespace std;
const int maxn=105;
int val[maxn],dp[maxn][5*maxn];
int n,t,d[maxn];
bool is[maxn];
struct node
{
    int to,cost;
};
vector<node>G[maxn];
void bfs()
{
    bool vis[maxn];
    int pre[maxn];
    memset(vis,0,sizeof(vis));
    memset(d,0,sizeof(d));
    queue<int>P;
    P.push(1);vis[1]=1;pre[1]=-1;
    while(!P.empty())
    {
        int v=P.front();P.pop();
        for(int i=0;i<G[v].size();i++)
        {
            node e=G[v][i];
            if(vis[e.to])continue;
            vis[e.to]=1;
            P.push(e.to);
            pre[e.to]=v;
            d[e.to]=d[v]+e.cost;
        }
    }
    int k=n;
    while(k!=-1)
    {
        //printf("%d\n",k);
        is[k]=1;
        k=pre[k];
    }
}
void dfs(int now,int fa)
{
    for(int i=0;i<=t;i++)
        dp[now][i]=val[now];
    for(int i=0;i<G[now].size();i++)
    {
        node e=G[now][i];
        if(e.to==fa)continue;
        dfs(e.to,now);
        for(int j=t;j>=0;j--)
        {
            for(int k=0;k+2*e.cost<=j;k++)
                dp[now][j]=max(dp[now][j],dp[now][j-k-2*e.cost]+dp[e.to][k]);
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&t))
    {
        memset(dp,0,sizeof(dp));
        memset(is,0,sizeof(is));
        for(int i=0;i<=n;i++)
            G[i].clear();
        for(int i=1;i<n;i++)
        {
            int x,y,z;scanf("%d%d%d",&x,&y,&z);
            G[x].push_back((node){y,z});
            G[y].push_back((node){x,z});
        }
        for(int i=1;i<=n;i++)
            scanf("%d",&val[i]);
        bfs();
        if(d[n]>t)
            printf("Human beings die in pursuit of wealth, and birds die in pursuit of food!\n");
        else
        {
            for(int i=1;i<=n;i++)
            {
                if(is[i])
                {
                    for(int j=0;j<G[i].size();j++)
                    {
                        node &e=G[i][j];
                        if(is[e.to])
                            e.cost=0;
                    }
                }
            }
            t-=d[n];
            //printf("%d\n",t);
            dfs(1,-1);
            printf("%d\n",dp[1][t]);
        }
    }
    return 0;
}
/*
4 4
1 2 1
2 4 2
1 3 1
1 1 10 1
*/

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值