HDU 3586 Information Disturbing(树形dp+二分)

Information Disturbing

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 4017    Accepted Submission(s): 1399


Problem Description
In the battlefield , an effective way to defeat enemies is to break their communication system.
The information department told you that there are n enemy soldiers and their network which have n-1 communication routes can cover all of their soldiers. Information can exchange between any two soldiers by the communication routes. The number 1 soldier is the total commander and other soldiers who have only one neighbour is the frontline soldier.
Your boss zzn ordered you to cut off some routes to make any frontline soldiers in the network cannot reflect the information they collect from the battlefield to the total commander( number 1 soldier).
There is a kind of device who can choose some routes to cut off . But the cost (w) of any route you choose to cut off can’t be more than the device’s upper limit power. And the sum of the cost can’t be more than the device’s life m.
Now please minimize the upper limit power of your device to finish your task.
 

Input
The input consists of several test cases. 
The first line of each test case contains 2 integers: n(n<=1000)m(m<=1000000).
Each of the following N-1 lines is of the form:
ai bi wi
It means there’s one route from ai to bi(undirected) and it takes wi cost to cut off the route with the device.
(1<=ai,bi<=n,1<=wi<=1000)
The input ends with n=m=0.
 

Output
Each case should output one integer, the minimal possible upper limit power of your device to finish your task. 
If there is no way to finish the task, output -1.
 

Sample Input
 
 
5 5 1 3 2 1 4 3 3 5 5 4 2 6 0 0
 

Sample Output
 
 
3

二分+树形dp
#include<bits/stdc++.h>
using namespace std;
const int maxn=1005;
int dp[maxn],n,m;
struct node
{
    int to,cost;
};
vector<node>G[maxn];
void dfs(int now,int fa,int x)
{
    if(G[now].size()==1&&G[now][0].to==fa)
        dp[now]=1e6+7;
    else dp[now]=0;
    for(int i=0;i<G[now].size();i++)
    {
        node e=G[now][i];
        if(e.to==fa)continue;
        dfs(e.to,now,x);
        if(e.cost<=x)
            dp[now]+=min(dp[e.to],e.cost);
        else
            dp[now]+=dp[e.to];
    }
}
bool pp(int x)
{
    dfs(1,-1,x);
    if(dp[1]<=m)return 1;
    return 0;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)break;
        for(int i=0;i<=n;i++)
            G[i].clear();
        int ma=0;
        for(int i=1;i<n;i++)
        {
            int x,y,z;scanf("%d%d%d",&x,&y,&z);
            G[x].push_back((node){y,z});
            G[y].push_back((node){x,z});
            ma=max(ma,z);
        }
        int l=0,r=ma+2;
        while(r-l>1)
        {
            int mid=(l+r)/2;
            if(pp(mid))r=mid;
            else l=mid;
        }
        if(r>ma)printf("-1\n");
        else printf("%d\n",r);
    }
    return 0;
}


也可直接求解,但时间复杂度较高。
#include<bits/stdc++.h>
using namespace std;
const int maxn=1005;
struct node
{
    int to,cost;
};
vector<node>G[maxn];
int dp[maxn][maxn],n,m;
void dfs(int now,int fa)
{
    if(G[now].size()==1&&G[now][0].to==fa)
        for(int i=0;i<maxn;i++)
        dp[now][i]=1e6+7;
    else
        for(int i=0;i<maxn;i++)
        dp[now][i]=0;
    for(int i=0;i<G[now].size();i++)
    {
        node e=G[now][i];
        if(e.to==fa)continue;
        dfs(e.to,now);
        for(int j=maxn-1;j>=0;j--)
        {
            if(e.cost>j)
                dp[now][j]+=dp[e.to][j];
            else
                dp[now][j]+=min(dp[e.to][j],e.cost);
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)break;
        for(int i=0;i<=n;i++)
            G[i].clear();
        int ma=0;
        for(int i=1;i<n;i++)
        {
            int x,y,z;scanf("%d%d%d",&x,&y,&z);
            G[x].push_back((node){y,z});
            G[y].push_back((node){x,z});
            ma=max(ma,z);
        }
        dfs(1,-1);
        for(int i=1;i<=ma;i++)
        {
            if(dp[1][i]<=m)
            {
                printf("%d\n",i);
                break;
            }
            if(i==ma)printf("-1\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值