HDU 5151 Sit sit sit(区间dp)

Sit sit sit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 531    Accepted Submission(s): 276


Problem Description
There are  N chairs in a row and and no one on the chairs.Each chair is blue or red.Then comes  N students one by one numbered 1,2,3,..,N.For each student, he will find an empty chair to sit on.He won’t sit on the chair if the chair is satisfied the following three conditions.

1.The chair has both left and right adjacent chairs.
2.The left and right adjacent chairs are not empty.
3.The left and right adjacent chairs’ color are different.
If the current student can’t find a chair to sit on, he will go away.

For each student, he may have many choices of chairs to sit on. Your task is to find the number of distinct situations that all students have sat on a chair. As the answer can be rather large, find remainder after dividing the number by  1000000007(109+7).
 

Input
There are several test cases.
In each test case:
The first line contains a integer  N(1N100).The second line contains  N integers.Each integer is either 0 or 1.Integer 0 means blue and 1 means red.
 

Output
For each test case, output the remainder of division of the resulting number by  1000000007(109+7).
 

Sample Input
 
 
3 1 0 0 4 1 0 0 1
 

Sample Output
 
 
4 8

#include<bits/stdc++.h>
using namespace std;
#define ll long long
const ll mod=1e9+7;
const int maxn=105;
ll dp[maxn][maxn],c[maxn][maxn];
int a[maxn];
int main()
{
    c[0][0]=1;
    for(int i=1;i<=100;i++)//打表
    {
        c[i][0]=1;
        for(int j=1;j<=i;j++)
            c[i][j]=(c[i-1][j-1]+c[i-1][j])%mod;
    }
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        memset(dp,0,sizeof(dp));
        for(int i=n;i>=1;i--)
        {
            dp[i][i]=1;
            for(int j=i+1;j<=n;j++)
            {
                for(int k=i;k<=j;k++)//枚举区间i~j最后一个放k
                {
                    if(k==i) dp[i][j]+=dp[k+1][j];//两侧直接加
                    else if(k==j) dp[i][j]+=dp[i][k-1];
                    else if(a[k-1]==a[k+1])//两边同色才能放,j-i个人选k-i个放到i~k-1
                    dp[i][j]+=(c[j-i][k-i]*dp[i][k-1]%mod*dp[k+1][j]%mod);
                    dp[i][j]%=mod;
                }
            }
        }
        printf("%lld\n",dp[1][n]);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值