「USACO16OPEN」「LuoguP3147」262144(区间dp

P3147 [USACO16OPEN]262144

题目描述

Bessie likes downloading games to play on her cell phone, even though she doesfind the small touch screen rather cumbersome to use with her large hooves.

She is particularly intrigued by the current game she is playing.The game starts with a sequence of NNN positive integers (2≤N≤262,1442 \leq N\leq 262,1442N262,144), each in the range 1…401 \ldots 40140. In one move, Bessiecan take two adjacent numbers with equal values and replace them asingle number of value one greater (e.g., she might replace twoadjacent 7s with an 8). The goal is to maximize the value of thelargest number present in the sequence at the end of the game. Pleasehelp Bessie score as highly as possible!

Bessie喜欢在手机上下游戏玩(……),然而她蹄子太大,很难在小小的手机屏幕上面操作。

她被她最近玩的一款游戏迷住了,游戏一开始有n个正整数,(2<=n<=262144),范围在1-40。在一步中,贝西可以选相邻的两个相同的数,然后合并成一个比原来的大一的数(例如两个7合并成一个8),目标是使得最大的数最大,请帮助Bessie来求最大值。

输入输出格式

输入格式:

The first line of input contains NNN, and the next NNN lines give the sequence

of NNN numbers at the start of the game.

输出格式:

Please output the largest integer Bessie can generate.

输入输出样例

输入样例#1: 复制
4
1
1
1
2
输出样例#1: 复制
3

说明

In this example shown here, Bessie first merges the second and third 1s to

obtain the sequence 1 2 2, and then she merges the 2s into a 3. Note that it is

not optimal to join the first two 1s.


 

题解

上一题「USACO16OPEN」「LuoguP3146」248(区间dp的数据加强版

显然那种略暴力的O(n^3)已经不行了(N三过十万,暴力赛标算!!!)

所以我们要再找条路。 

记f[x][i]=y,
其中i为当前被处理区间的起始位置,
y为当前处理区间的终止位置后一位,
x为这个区间的ans。

初始化f[a[i]][i]=i+1。
转移方程:
f[i][j]=max(f[i][j],f[i-1][f[i-1][j]]);
if(f[i][j])ans=max(ans,i);

其中因为i在循环时单调递增,
所以可以直接写为ans=i。

因为262144=218,所以答案的最大值只会到40+18=58。

所以i从2循环到59,j从1循环到n即可。

/*
    qwerta
    P3147 [USACO16OPEN]262144
    Accepted
    100
    代码 C++,0.46KB
    提交时间 2018-09-18 18:42:45
    耗时/内存
    1423ms, 62508KB
*/
#include<cmath>
#include<cstdio>
#include<iostream>
using namespace std;
#define R register
int f[63][262147];
int main()
{
    //freopen("a.in","r",stdin);
    int n;
    scanf("%d",&n);
    for(R int i=1;i<=n;++i)
    {
        int x;
        scanf("%d",&x);
        f[x][i]=i+1;
    }
    int ans=0;
    for(R int i=2;i<=59;++i)
    for(R int j=1;j<=n;++j)
    {
        f[i][j]=max(f[i][j],f[i-1][f[i-1][j]]);
        if(f[i][j])ans=i;
    }
    cout<<ans;
    return 0;
}

 

转载于:https://www.cnblogs.com/qwerta/p/9670862.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值