洛谷P3147 [USACO16OPEN]262144

P3147 [USACO16OPEN]262144

题目描述

Bessie likes downloading games to play on her cell phone, even though she doesfind the small touch screen rather cumbersome to use with her large hooves.

She is particularly intrigued by the current game she is playing.The game starts with a sequence of NN positive integers (2 \leq N\leq 262,1442N262,144), each in the range 1 \ldots 40140. In one move, Bessiecan take two adjacent numbers with equal values and replace them asingle number of value one greater (e.g., she might replace twoadjacent 7s with an 8). The goal is to maximize the value of thelargest number present in the sequence at the end of the game. Pleasehelp Bessie score as highly as possible!

Bessie喜欢在手机上下游戏玩(……),然而她蹄子太大,很难在小小的手机屏幕上面操作。

她被她最近玩的一款游戏迷住了,游戏一开始有n个正整数,(2<=n<=262144),范围在1-40。在一步中,贝西可以选相邻的两个相同的数,然后合并成一个比原来的大一的数(例如两个7合并成一个8),目标是使得最大的数最大,请帮助Bessie来求最大值。

输入输出格式

输入格式:

 

The first line of input contains NN, and the next NN lines give the sequence

of NN numbers at the start of the game.

 

输出格式:

 

Please output the largest integer Bessie can generate.

 

输入输出样例

输入样例#1:
4
1
1
1
2
输出样例#1:
3

说明

In this example shown here, Bessie first merges the second and third 1s to

obtain the sequence 1 2 2, and then she merges the 2s into a 3. Note that it is

not optimal to join the first two 1s.

/*
    一种 做法类似倍增 动归 递推 
    f[i][j] 表示 从第i--f[i][j]-1 位这几位的和是 j 
    然后就可以递推 或者说动归了,因为要相同j是由前后两个相同 j-1合并而来的, 
    f[i][j]=f[f[i][j-1]][j-1] 合并当然是从小到大合并的 
    因为先把小的合并了,大的合并机会才会更多嘛,另一个理由就是根据公式,
    在算 j 时 需要事先算出 i-1 才行
*/
#include <cstdio>
#define max(a,b) a>b?a:b
int x,n,ans=0;
int f[60][270000];
int main(){
    scanf("%d",&n);
    for (int i=1;i<=n;++i)
        scanf("%d",&x),f[x][i]=i+1;
    for (int i=2;i<=58;++i)
        for (int j=1;j<=n;++j){
            if (!f[i][j]) f[i][j]=f[i-1][f[i-1][j]];
            if (f[i][j]) ans=i;
        }
    printf("%d\n",ans);
}

 

转载于:https://www.cnblogs.com/thmyl/p/7604072.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值