PTA学生成绩链表处理

本题要求实现两个函数,一个将输入的学生成绩组织成单向链表;另一个将成绩低于某分数线的学生结点从链表中删除。

函数接口定义:

struct stud_node *createlist(); 
struct stud_node *deletelist( struct stud_node *head, int min_score );

函数createlist利用scanf从输入中获取学生的信息,将其组织成单向链表,并返回链表头指针。链表节点结构定义如下:

struct stud_node {
    int num; /*学号*/ 
    char name[20]; /*姓名*/
    int score; /*成绩*/ 
    struct stud_node *next; /*指向下个结点的指针*/
 };

输入为若干个学生的信息(学号、姓名、成绩),当输入学号为0时结束。

函数deletelist从以head为头指针的链表中删除成绩低于min_score的学生,并返回结果链表的头指针。

裁判测试程序样例:

 
#include <stdio.h>
#include <stdlib.h>

struct stud_node {
     int    num;
     char   name[20];
     int    score;
     struct stud_node *next;
};

struct stud_node *createlist();
struct stud_node *deletelist( struct stud_node *head, int min_score );

int main()
{
    int min_score;
    struct stud_node *p, *head = NULL;

    head = createlist();
    scanf("%d", &min_score);
    head = deletelist(head, min_score);
    for ( p = head; p != NULL; p = p->next )
        printf("%d %s %d\n", p->num, p->name, p->score);

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1 zhang 78
2 wang 80
3 li 75
4 zhao 85
0
80

输出样例:

2 wang 80
4 zhao 85

解题思路:

createlist函数要求最后返回头指针,所以定义一个头指针*head用于返回,定义一个尾指针*tail用于添加节点,定义指针一个*s接收scanf输入的值。

deletelist函数定义一个指针*p用于遍历链表,定义一个*n来删除节点。

若是代码看不懂,可以评论交流,看到了会回复的。

struct stud_node* createlist()
{
	struct stud_node* head, * tail, * s;
	head = (struct stud_node*)malloc(sizeof(struct stud_node));
	head->next = NULL; tail = head;
	while (1)
	{
		s = (struct stud_node*)malloc(sizeof(struct stud_node));
		scanf("%d", &s->num);
		if (s->num == 0)break;
		scanf("%s", s->name);
		scanf("%d", &s->score);
		s->next = NULL;
		tail->next = s;
		tail = s;
	}
	return head;
}

struct stud_node* deletelist(struct stud_node* head, int min_score)
{
	struct stud_node* p, * n;
	p = head->next;
	while (p != NULL)
	{
		if (p->score < min_score)
		{
			n = head;
			while (n->next != p)
				n = n->next;
			n->next = p->next;
			free(p);
		}
		p = p->next;
	}
	return head->next;
}
  • 16
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值