浙大PTA 第7章-1 词频统计 (30 分)

请编写程序,对一段英文文本,统计其中所有不同单词的个数,以及词频最大的前10%的单词。

所谓“单词”,是指由不超过80个单词字符组成的连续字符串,但长度超过15的单词将只截取保留前15个单词字符。而合法的“单词字符”为大小写字母、数字和下划线,其它字符均认为是单词分隔符。

输入格式:

输入给出一段非空文本,最后以符号#结尾。输入保证存在至少10个不同的单词。

输出格式:

在第一行中输出文本中所有不同单词的个数。注意“单词”不区分英文大小写,例如“PAT”和“pat”被认为是同一个单词。

随后按照词频递减的顺序,按照词频:单词的格式输出词频最大的前10%的单词。若有并列,则按递增字典序输出。

输入样例:

This is a test.

The word "this" is the word with the highest frequency.

Longlonglonglongword should be cut off, so is considered as the same as longlonglonglonee.  But this_8 is different than this, and this, and this...#
this line should be ignored.

输出样例:(注意:虽然单词the也出现了4次,但因为我们只要输出前10%(即23个单词中的前2个)单词,而按照字母序,the排第3位,所以不输出。)

23
5:this
4:is

题解:

s=''
while True:
    a=input()
    if s and s[-1]=='#':
        break
    else:
        s+=a
s=s[:s.find('#')]
# print(s)
li = list(s)
for i in range(len(li)):
    if not li[i].isalnum() and li[i]!='_':
        li[i]=' '
li1=''.join(li).split()
dic={}
for i in li1:
    if len(i)>15:
        i=i[:15]
    if i.lower() not in dic:
        dic[i.lower()]=1
    else:
        dic[i.lower()]+=1
print(len(dic))
dic={'this': 5, 'is': 4, 'a': 1, 'test': 1, 'the': 4, 'word': 2, 'with': 1, 'highest': 1, 'frequency': 1, 'longlonglonglon': 2, 'should': 1, 'be': 1, 'cut': 1, 'off': 1, 'so': 1, 'considered': 1, 'as': 2, 'same': 1, 'but': 1, 'this_8': 1, 'different': 1, 'than': 1, 'and': 2} 
li2=sorted(dic.items(),key=lambda x:-x[1])
# print(li2,len(dic)//10)
for i in range(len(dic)//10):
    print(f'{li2[i][1]}:{li2[i][0]}')

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值