Palindromes

Palindromes
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu


描述
    A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.


A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is a mirrored string because "A" and "I" are their own reverses, and "3" and "E" are each others' reverses.


A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string "ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string.


Of course,"A","T", "O", and "Y" are all their own reverses.


A list of all valid characters and their reverses is as follows.


Character Reverse            Character          Reverse         Character Reverse
A                               A M                    M Y                           Y
B                                                              N                                                 Z                            5
C                                                              O                     O                        1                             1
D                                                              P                                                 2                            S
E                              3 Q                                                3                            E
F                                                               R                                                 4  
G                                                               S                       2                       5                            Z
H                             H                               T                      T                       6  
I                                I U                      U                       7  
J                              L V                      V                       8                            8
K                                                               W                      W 9  
L                             J X                       X  
  
Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.
Input


    Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.
Output


    For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.


STRING CRITERIA
" -- is not a palindrome." if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome." if the string is a palindrome and is not a mirrored string
" -- is a mirrored string." if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome." if the string is a palindrome and is a mirrored string
Note that the output line is to include the -'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.


In addition, after each output line, you must print an empty line.
Sample Input
NOTAPALINDROME
ISAPALINILAPASI
2A3MEAS
ATOYOTA
Sample Output
NOTAPALINDROME -- is not a palindrome.
 
ISAPALINILAPASI -- is a regular palindrome.
 
2A3MEAS -- is a mirrored string.
 

ATOYOTA -- is a mirrored palindrome.



判断回文与镜像

#include<stdio.h>
#include<string.h>
char a[10000000];
char c[10000000];
int huiwen(char a[])                 //判断回文
{
    int i,j,k,l,x;
    l=strlen(a);
    for(i=0; i<l; i++)
    {
        if(a[i]!=a[l-1-i])
            break;
    }
    if(i==l)
        x=1;
    else
        x=0;
    return x;
}
int jingxiang(char a[])               //判断镜像
{
    int i,j,k,l,t;
    l=strlen(a);
    char b[22]= {'A','E','3','H','I','L','J','M','O','2','S','T','U','V','W','X','Y','5','Z','1','8'};
    char d[22]= {'A','3','E','H','I','J','L','M','O','S','2','T','U','V','W','X','Y','Z','5','1','8'};

    for(i=0,j=l-1; i<l; j--,i++)           //c数组把a数组反过来存储。
        c[i]=a[j];

    for(i=0; i<l; i++)
    {
        for(j=0; j<22; j++)                 //对于a中每一个字符,判断他是否属于镜像元素。
        {
            if(a[i]==b[j])
                break;
        }
        if(j==22)
            break;
    }
    if(i<l)
        t=0;
    else                               //如果是的话,判断他与反过来的c数组中的元素是否一一对应
    {

        for(i=0; i<l; i++)
        {
            for(j=0; j<22; j++)
            {
                if(a[i]==b[j])        //从b数组中找到该元素
                    break;
            }
            if(c[i]!=d[j])           //此时的c[i]应该与d[j]相等,若不相等,则不是镜像。
                break;
        }
        if(i<l)
            t=0;
        else
            t=1;
    }
    return t;
}
int main()
{
    memset(a,0,sizeof(a));
    memset(c,0,sizeof(c));
    while(gets(a))
    {
        int x,t;

        x=huiwen(a);
        t=jingxiang(a);

        if(t==0&&x==0)
            printf("%s -- is not a palindrome.\n\n",a);
        if(x==1&&t==0)
            printf("%s -- is a regular palindrome.\n\n",a);
        if(x==1&&t==1)
            printf("%s -- is a mirrored palindrome.\n\n",a);
        if(x==0&&t==1)
            printf("%s -- is a mirrored string.\n\n",a);
        memset(a,0,sizeof(a));
        memset(c,0,sizeof(c));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值