PAT A1025 PAT Ranking(25)

题目描述

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

输入格式

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

输出格式

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:
                                    
                registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

输入样例

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

输出样例

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

全部AC

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
//p115
using namespace std;

const int maxn = 30010;

struct Student {
    char registration_number[20]; //考生id
    int score; //考生成绩
    int final_rank; //最终排名
    int location_number; //考室号
    int local_rank; //考室排名
}stu[maxn];

bool cmp(Student A, Student B) {
    if(A.score != B.score) return A.score > B.score; //AB成绩不同,按成绩从大到小排序
    else if(A.score == B.score) return strcmp(A.registration_number, B.registration_number) < 0; //AB成绩相同,则按照准考证从小到大排序
}

int main(){
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif // ONLINE_JUDGE}
    int N; //考室数量
    scanf("%d", &N);
    int a = 0; //初始化考生存储位置
    for(int i = 0; i < N; i++) {
        int K; //考室中考生的数量
        scanf("%d", &K);
        //输入各个考室考生的注册号和成绩
        for(int j = 0; j < K; j++) {
            stu[a].location_number = i + 1;
            scanf("%s %d", stu[a].registration_number, &stu[a].score);
            a++;
        }
    }
    //初始化每个教室排名
    int lrank[N+1] = {0};
    int lrealrank[N+1] = {0};
    //memset(lrank, 1, N+1);
    //按考生成绩从大到小排序
    sort(stu, stu+a, cmp);
    int rank = 1; //总排名
    for(int i = 0; i < a; i++) {
        //printf("registration_number:%s location_number:%d score:%d \n", stu[i].registration_number, stu[i].location_number, stu[i].score);
        //总排名
        if(i == 0) stu[i].final_rank = rank;
        else if(i != 0 && stu[i].score == stu[i-1].score) stu[i].final_rank = stu[i-1].final_rank;
        else if(stu[i].score < stu[i-1].score) stu[i].final_rank = ++rank;
        rank = i+1; //更新总排名
        //教室排名
        if(i != 0 && stu[i].score == stu[i-1].score && stu[i].location_number == stu[i-1].location_number) { //在同个教室中分数相同
                stu[i].local_rank = stu[i-1].local_rank;
                lrealrank[stu[i].location_number]++;
        } else {
            stu[i].local_rank = lrank[stu[i].location_number]; //在同个教室中分数不相同
            lrank[stu[i].location_number]++;
            lrealrank[stu[i].location_number]++;
        }
        lrank[stu[i].location_number] = lrealrank[stu[i].location_number];
    }
    printf("%d\n", a);
    for(int i = 0; i < a; i++) {
        printf("%s %d %d %d\n", stu[i].registration_number, stu[i].final_rank, stu[i].location_number, stu[i].local_rank+1);
    }
    return 0;
}

转载于:https://www.cnblogs.com/isChenJY/p/11444667.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园整体解决方案是响应国家教育信息化政策,结合教育改革和技术创新的产物。该方案以物联网、大数据、人工智能和移动互联技术为基础,旨在打造一个安全、高效、互动且环保的教育环境。方案强调从数字化校园向智慧校园的转变,通过自动数据采集、智能分析和按需服务,实现校园业务的智能化管理。 方案的总体设计原则包括应用至上、分层设计和互联互通,确保系统能够满足不同用户角色的需求,并实现数据和资源的整合与共享。框架设计涵盖了校园安全、管理、教学、环境等多个方面,构建了一个全面的校园应用生态系统。这包括智慧安全系统、校园身份识别、智能排课及选课系统、智慧学习系统、精品录播教室方案等,以支持个性化学习和教学评估。 建设内容突出了智慧安全和智慧管理的重要性。智慧安全管理通过分布式录播系统和紧急预案一键启动功能,增强校园安全预警和事件响应能力。智慧管理系统则利用物联网技术,实现人员和设备的智能管理,提高校园运营效率。 智慧教学部分,方案提供了智慧学习系统和精品录播教室方案,支持专业级学习硬件和智能化网络管理,促进个性化学习和教学资源的高效利用。同时,教学质量评估中心和资源应用平台的建设,旨在提升教学评估的科学性和教育资源的共享性。 智慧环境建设则侧重于基于物联网的设备管理,通过智慧教室管理系统实现教室环境的智能控制和能效管理,打造绿色、节能的校园环境。电子班牌和校园信息发布系统的建设,将作为智慧校园的核心和入口,提供教务、一卡通、图书馆等系统的集成信息。 总体而言,智慧校园整体解决方案通过集成先进技术,不仅提升了校园的信息化水平,而且优化了教学和管理流程,为学生、教师和家长提供了更加便捷、个性化的教育体验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值