POJ 2240 Arbitrage(最短路,floyd)

Arbitrage
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 24461 Accepted: 10353

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

Source


题意是输入N个国家的货币种类,再输入M种兑换关系。比如USDollar 0.5 BritishPound代表1USDollar 可以兑换0.5BritishPound,以此类推,可以换得5FrenchFranc,然后可以获得1.05 USDollar >1,因此输出Yes。否则输出No。

用floyd求出所有货币之间的最短路径,最后判断每种货币到各自货币是否存在正环。即是否ma[i][i]>1。开始时i到i设为1,其余的设为0。因为求得是最大值,所以*0=0也没关系。

输入的时候要注意根据字符串来建立结点,所以最好用map容器来建立。

代码如下:

#include <stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<map>
#include<string>
#include<iostream>
using namespace std;
char a[30],b[30];
double ma[35][35];
int n;
void floyd()
{
    for(int k=1;k<=n;k++)
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                if(ma[i][k]!=0&&ma[k][j]!=0)
                    if(ma[i][j]<ma[i][k]*ma[k][j])
                        ma[i][j]=ma[i][k]*ma[k][j];
}
int main()
{
    map<char,int> s_map;
    int p=1;
    while(scanf("%d",&n)!=EOF&&n)
    {
        memset(ma,0,sizeof(ma));
        getchar();
        for(int i=1;i<=n;i++)
            {
                scanf("%s",a);
                s_map[*a]=i;
                ma[i][i]=1;
            }
        int t;
        scanf("%d",&t);
        getchar();
        while(t--)
        {
            double m;
            scanf("%s %lf %s",a,&m,b);
            ma[s_map[*a]][s_map[*b]]=m;
        }
        floyd();
        int flag=0;
        for(int i=1;i<=n;i++)
        {
            if(ma[i][i]>1) {flag=1;break;}
        }
        if(flag) printf("Case %d: Yes\n",p++);
        else printf("Case %d: No\n",p++);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值