HDU1069

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food. 

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks. 
Input
The input file will contain one or more test cases. The first line of each test case contains an integer n, 
representing the number of different blocks in the following data set. The maximum value for n is 30. 
Each of the next n lines contains three integers representing the values xi, yi and zi. 
Input is terminated by a value of zero (0) for n. 
Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height". 
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题意:现在有n个方块,并且每个方块都有一定的长宽高,猴子要用方块搭建尽可能高的塔去拿香蕉,并且限制条件是上一层的方块长和宽得分别小于下一层方块的长和宽。

因为有n个方块,就是有3n种方块的摆法,注意:当方块的长宽高一样是,无论哪个面,摆法都一样。

竟然有个限制条件和可选的物品,那么开始dp。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct node
{
    int l,w,h;
}a[200];
int num;
int ini(int t1,int t2,int t3)
{
    a[num].l=t1;
    a[num].w=t2;
    a[num].h=t3;
    num++;
}
int dp[200];
bool cmp(const node &a,const node &b)
{
    if(a.l==b.l)return a.w<b.w;
    return a.l<b.l;
}
int main()
{
    int n;
    int kase=0;
    while(cin>>n&&n)
    {
        num=0;
        for(int i=0;i<n;i++)
        {
            int a1,a2,a3;
            cin>>a1>>a2>>a3;
            if(a1==a2&&a1==a3)
            {
                ini(a1,a2,a3);
            }
            else
            {
                ini(a1,a2,a3);
                ini(a1,a3,a2);
                ini(a2,a1,a3);
                ini(a2,a3,a1);
                ini(a3,a1,a2);
                ini(a3,a2,a1);
            }
        }
        memset(dp,0,sizeof(dp));
        sort(a,a+num,cmp);
        dp[0]=a[0].h;
        int MAX=0;
        for(int i=1;i<num;i++)
        {
            int Max=0;
            for(int j=i-1;j>=0;j--)
            {
                if(a[i].l>a[j].l&&a[i].w>a[j].w&&dp[j]>Max)
                    Max=dp[j];
            }
            dp[i]=Max+a[i].h;
            MAX=max(MAX,dp[i]);
        }
        printf("Case %d: maximum height = %d\n",++kase,MAX);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值