求奇数的乘积

Problem Description
给你n个整数,求他们中所有奇数的乘积。
 Input
输入数据包含多个测试实例,每个测试实例占一行,每行的第一个数为n,表示本组数据一共有n个,接着是n个整数,你可以假设每组数据必定至少存在一个奇数。
 Output
输出每组数中的所有奇数的乘积,对于测试实例,输出一行。
 Sample Input
3 1 2 3
4 2 3 4 5
 Sample Output
3
15
 
 
code:

#include<stdio.h>
int main()
{
      int n,i,a[100];
       while(scanf("%d",&n)!=EOF)                                              error C2466: cannot allocate an array of constant size 0
        {                                                   不能在此int a[n];否则error C2133: 'a' : unknown size;error C2057: expected constant expression;

              int s=1;
             for(i=0;i<n;i++)
            {
                scanf("%d",&a[i]);
                if(a[i]%2!=0)
                     s=s*a[i];
             }
         printf("%d\n",s);         //若掉\n则Presentation Error
}
return 0;
}

 

code2:

#include<stdio.h>
int main()
{
    int n,i,m;                                                    //可用m替换a[i];
    while(scanf("%d",&n)!=EOF)
    {

         int s=1;
         for(i=0;i<n;i++)
         {
                scanf("%d",&m);
                 if(m%2!=0)
                 s=s*m;
         }
         printf("%d\n",s);
     }
    return 0;
}

 

 
 

转载于:https://www.cnblogs.com/gongpulin/p/3876374.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值