POJ 3349-Snowflake Snow Snowflakes

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5
Sample Output

Twin snowflakes found.
Source

CCC 2007
.
.
.
.
.

程序:
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int n,tot,p=99991,snow[200001][6],head[200001],next[200001];

int hash(int *a)
{
    int sum=0,mul=1;
    for (int i=0;i<6;i++)
    {
        sum=(sum+a[i])%p;
        mul=(long long)mul*a[i]%p;
    }
    return (sum+mul)%p;
}

bool check(int *a,int *b)
{
    for (int i=0;i<6;i++)
        for (int j=0;j<6;j++)
        {
            bool eq=true;
            for (int k=0;k<6;k++)
                if (a[(i+k)%6]!=b[(j+k)%6]) eq=false;
            if (eq==true) return true;
            eq=true;
            for (int k=0;k<6;k++)
                if (a[(i+k)%6]!=b[(j-k+6)%6]) eq=false;
            if (eq==true) return true;
        }
    return 0;
}

bool insert(int *a)
{
    int val=hash(a);
    for (int i=head[val];i;i=next[i])
        if (check(snow[i],a)) return 1;
    tot++;
    memcpy(snow[tot],a,6*sizeof(int));
    next[tot]=head[val];
    head[val]=tot;
    return 0;
}

int main()
{
    cin>>n;
    for (int i=1;i<=n;i++)
    {
        int a[10];
        for (int j=0;j<6;j++) scanf("%d",&a[j]);
        if (insert(a))
        {
            puts("Twin snowflakes found.");
            return 0;
        }
    }
    puts("No two snowflakes are alike.");
    return 0;
}

转载于:https://www.cnblogs.com/YYC-0304/p/9499893.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值