poj 3349(hash)

很久就听说过hash了,但是一直没有做过相关的题目。

题意大概就是给你n个雪花,每个雪花有六个花瓣代表六个值,判断是否有至少一对相同的雪花。

由于n值较大,而且每次要判断6个数,我开始根据我自己学的一点hash的知识,先存起来,然后求6个值的和取余一个值,存在一个数组里面,然后每次向前找所有的如果有相同的,则比较六个值,超时了。后来看了别人的写法,发现弱爆了。那样找的话很慢。

其实差别就在存的时候,每一个雪花求和取余一个数,作为建值,如果有相同的在键值后面保存起来,没次值找键值里面的,快速了很多。

题目:

Snowflake Snow Snowflakes
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 28891 Accepted: 7622

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.
代码:这里是用数组实现的,内存有要求的题目需要用链表实现

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int K = 14997;

struct Node
{
    int floor[7];
};
int m[15000];
Node snow[15000][100];
bool solve(Node x,Node y)  //比较
{
    sort(x.floor,x.floor+6);
    sort(y.floor,y.floor+6);
    for(int i=0;i<6;i++)
    {
        if(x.floor[i]!=y.floor[i])
            return false;
    }
    return true;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(m,0,sizeof(m));
        int ok=0;
        for(int i=0; i<n; i++)
        {
            int sum=0;
            Node pp;
            for(int j=0; j<6; j++)
            {
                scanf("%d",&pp.floor[j]);
                sum=(sum+pp.floor[j])%14997;
            }
            if(ok==0)
            {
                for(int j=0; j<m[sum]; j++) //按键值查找
                {
                    if(solve(pp,snow[sum][j])){
                        ok=1;break;
                    }
                }
                snow[sum][m[sum]]=pp;
                m[sum]++;
            }
        }
        if(ok)
            printf("Twin snowflakes found.\n");
        else
            printf("No two snowflakes are alike.\n");
    }
    return 0;
}


  • 5
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 7
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 7
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值