A - Five, Five Everywhere

标题 A - Five, Five Everywhere

A - Five, Five Everywhere

Problem Statement
Print a sequence a1,a2,…,aN whose length is N that satisfies the following conditions:
ai (1≤i≤N) is a prime number at most 55 555.
The values of a1,a2,…,aN are all different.
In every choice of five different integers from a1,a2,…,aN, the sum of those integers is a composite number.
If there are multiple such sequences, printing any of them is accepted.

Notes
An integer N not less than 2 is called a prime number if it cannot be divided evenly by any integers except 1 and N and called a composite number otherwise.

Constraints
N is an integer between 5 and 55 (inclusive).

Input
Input is given from Standard Input in the following format:N

Output
Print
N numbers a1,a2,a3,…,aN in a line, with spaces in between.

Sample Input 1
5
Sample Output 1
3 5 7 11 31
Let us see if this output actually satisfies the conditions.
First,
3, 5, 7, 11 and 31 are all different, and all of them are prime numbers.
The only way to choose five among them is to choose all of them, whose sum is a1+a2+a3+a4+a5=57, which is a composite number.
There are also other possible outputs, such as 2 3 5 7 13, 11 13 17 19 31 and 7 11 5 31 3.

Sample Input 2
6
Sample Output 2
2 3 5 7 11 13
2, 3, 5, 7, 11, 13 are all different prime numbers.
2+3+5+7+11=28 is a composite number.
2+3+5+7+13=30 is a composite number.
2+3+5+11+13=34 is a composite number.
2+3+7+11+13=36 is a composite number.
2+5+7+11+13=38 is a composite number.
3+5+7+11+13=39 is a composite number.
Thus, the sequence 2 3 5 7 11 13 satisfies the conditions.

Sample Input 3
8
Sample Output 3
2 5 7 13 19 37 67 79

题意:输入一个整数N,输出N个质数,使这N个质数中任意五个数相加的和为合数(非质数)。

解题思路:
输出N个位数字是1的质数,这样的话不论取哪五个数相加其和的个位必是5,也就是可以被5整除,这个数就是个合数。代码如下:

#include"stdio.h"
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		int b=0;
		for(int j=5;j<=55555;j++)
		{
			int flag=0;
			for(int i=2;i<j;i++)
			{
				if(j%i==0)
				{
					flag=1;
					
				}
			}
			if(flag!=1&&j%10==1)
			{
				if(b<n-1)
				{
					printf("%d ",j);
				}
				if(b==n-1)
				{
					printf("%d\n",j);
                    break;
				}
				b++;
			}
		}
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值