Two Stacks In One Array

6-1 Two Stacks In One Array (20 分)

Write routines to implement two stacks using only one array. Your stack routines should not declare an overflow unless every slot in the array is used.

Format of functions:

Stack CreateStack( int MaxElements );
int IsEmpty( Stack S, int Stacknum );
int IsFull( Stack S );
int Push( ElementType X, Stack S, int Stacknum );
ElementType Top_Pop( Stack S, int Stacknum );

where int Stacknum is the index of a stack which is either 1 or 2; int MaxElements is the size of the stack array; and Stack is defined as the following:

typedef struct StackRecord *Stack;
struct StackRecord  {
    int Capacity;       /* maximum size of the stack array */
    int Top1;           /* top pointer for Stack 1 */
    int Top2;           /* top pointer for Stack 2 */
    ElementType *Array; /* space for the two stacks */
}

Note: Push is supposed to return 1 if the operation can be done successfully, or 0 if fails. If the stack is empty, Top_Pop must return ERRORwhich is defined by the judge program.

Sample program of judge:

#include <stdio.h>
#include <stdlib.h>
#define ERROR 1e8
typedef int ElementType;
typedef enum { push, pop, end } Operation;

typedef struct StackRecord *Stack;
struct StackRecord  {
    int Capacity;       /* maximum size of the stack array */
    int Top1;           /* top pointer for Stack 1 */
    int Top2;           /* top pointer for Stack 2 */
    ElementType *Array; /* space for the two stacks */
};

Stack CreateStack( int MaxElements );
int IsEmpty( Stack S, int Stacknum );
int IsFull( Stack S );
int Push( ElementType X, Stack S, int Stacknum );
ElementType Top_Pop( Stack S, int Stacknum );

Operation GetOp();  /* details omitted */
void PrintStack( Stack S, int Stacknum ); /* details omitted */

int main()
{
    int N, Sn, X;
    Stack S;
    int done = 0;

    scanf("%d", &N);
    S = CreateStack(N);
    while ( !done ) {
        switch( GetOp() ) {
        case push: 
            scanf("%d %d", &Sn, &X);
            if (!Push(X, S, Sn)) printf("Stack %d is Full!\n", Sn);
            break;
        case pop:
            scanf("%d", &Sn);
            X = Top_Pop(S, Sn);
            if ( X==ERROR ) printf("Stack %d is Empty!\n", Sn);
            break;
        case end:
            PrintStack(S, 1);
            PrintStack(S, 2);
            done = 1;
            break;
        }
    }
    return 0;
}

/* Your function will be put here */

Sample Input:

5
Push 1 1
Pop 2
Push 2 11
Push 1 2
Push 2 12
Pop 1
Push 2 13
Push 2 14
Push 1 3
Pop 2
End

Sample Output:

Stack 2 is Empty!
Stack 1 is Full!
Pop from Stack 1: 1
Pop from Stack 2: 13 12 11

作者: 陈越

单位: 浙江大学

时间限制: 400 ms

内存限制: 64 MB

代码长度限制: 16 KB

 

#include <stdio.h>
#include <stdlib.h>
#define ERROR 1e8
typedef int ElementType;
typedef enum { push, pop, end } Operation;

typedef struct StackRecord *Stack;
struct StackRecord {
	int Capacity;       /* maximum size of the stack array */
	int Top1;           /* top pointer for Stack 1 */
	int Top2;           /* top pointer for Stack 2 */
	ElementType *Array; /* space for the two stacks */
};

Stack CreateStack(int MaxElements)
{
	Stack s = (Stack)malloc(sizeof(struct StackRecord));
	s->Capacity = MaxElements;
	s->Top1 =-1;
	s->Top2 = MaxElements;
	s->Array=(int)malloc(sizeof(int)*MaxElements);
	return s;
	//在C语言中Array的下标从0到MaxElements-1,Top1和Top2分别从两头向中间标记
}
int IsEmpty(Stack S, int Stacknum)
{
	//当Top1和Top2等于CreateStack中赋予的原值时,返回1
	if (Stacknum == 1) {
		if (S->Top1 == -1)return 1;
		else return 0;
	}
	else if (Stacknum == 2) {
		if (S->Top2 == S->Capacity)return 1;
		else return 0;
	}
}
int IsFull(Stack S)
{
	//当Top1和Top2相差仅剩1时,Capacity已用完,栈满
	if (S->Top2-S->Top1==1)return 1;
	return 0;
}
int Push(ElementType X, Stack S, int Stacknum)
{
	//先将指针指向下一位置,再将X值赋予该位置的指针
	if (IsFull(S))return 0;
	if (Stacknum == 1)
		S->Array[++(S->Top1)] = X;
	else if (Stacknum == 2) 
		S->Array[--(S->Top2)] = X;

	return 1;
}
ElementType Top_Pop(Stack S, int Stacknum)
{
	//先将此处指针的值返回,再将指针移向上一位置
	if (IsEmpty(S, Stacknum))return ERROR;
	if (Stacknum == 1) {
		return S->Array[(S->Top1)--];
	}
	else if (Stacknum == 2) {
		return S->Array[(S->Top2)++];
	}
}

Operation GetOp()
{
	char s[100];
	scanf("%s", s);
	if (!strcmp(s, "Push")) return push;
	if (!strcmp(s, "Pop")) return pop;
	if (!strcmp(s, "End")) return end;

}
void PrintStack(Stack S, int Stacknum)
{
	printf("Pop from Stack %d:", Stacknum);
	while (!IsEmpty(S, Stacknum))
	{
		printf("%d ", Top_Pop(S, Stacknum));
	}
	puts("");
}

int main()
{
	int N, Sn, X;
	Stack S;
	int done = 0;
	scanf("%d", &N);
	S = CreateStack(N);
	while (!done) {
		switch (GetOp()) {
		case push:
			scanf("%d %d", &Sn, &X);
			if (!Push(X, S, Sn)) printf("Stack %d is Full!\n", Sn);
			break;
		case pop:
			scanf("%d", &Sn);
			X = Top_Pop(S, Sn);
			if (X == ERROR) printf("Stack %d is Empty!\n", Sn);
			break;
		case end:
			PrintStack(S, 1);
			PrintStack(S, 2);
			done = 1;
			break;
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值