Tree Traversals Again (25)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1

做了这道题 对中序遍历和先序遍历有了深入的理解


先序遍历是一旦已知一个节点 就输出它 然后相同的递归的访问左子树和右子树
中序遍历是一旦你已知一个节点后 先访问它的左子树 在回头输出这个节点 再访问它的右子树


所以说 中序遍历和先序遍历本质上访问到每个节点的顺序是一样的 只不过输出顺序不一样


push的过程就是不断压入当前根节点 先去访问左子树的过程 压入当前根节点其实就是先序遍历的过程 pop就是中序遍历 


那么已知先序遍历和中序遍历 后续遍历就求出来了
 
#include<iostream>
#include<cstdio>
#include<stack>
#include<cstring>
using namespace std;
void GetPostOrder(int *pre,int x1,int y1,int *in,int x2,int y2)
{
	if(y1<x1 || y2<x2) return ;
	int mid,i;
	for(i=x2;i<=y2;i++)
		if(in[i]==pre[x1]) break;
	mid=i;
	GetPostOrder(pre,x1+1,x1+mid-x2,in,x2,mid-1);
	GetPostOrder(pre,x1+mid-x2+1,y1,in,mid+1,y2);
	printf("%d ",pre[x1]);
	return ;
}

int main()
{
	int N,num;
	char cache[5];
	int pre[50],in[50],post[50];
	int a,b;
	while(cin>>N)
	{
		stack<int>S;
		a=b=0;
		while(a<N || b<N)
		{
			scanf("%s",cache);
			if(!strcmp("Push",cache)) 
			{
				scanf("%d",&num);
				S.push(num);
				pre[a++]=num;
			}
			else 
			{
				in[b++]=S.top();
				S.pop();
			   
			}
		}
		GetPostOrder(pre,0,a-1,in,0,b-1);
		cout<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值