Uva - 1585 - Score

Therefore, the score of ``OOXXOXXOOO" is 10 which is calculated by ``1+2+0+0+1+0+0+1+2+3".

You are to write a program calculating the scores of test results.

Input 

Your program is to read from standard input. The input consists of T test cases. The number of test cases Tis given in the first line of the input. Each test case starts with a line containing a string composed by `O' and `X' and the length of the string is more than 0 and less than 80. There is no spaces between `O' and `X'.

Output 

Your program is to write to standard output. Print exactly one line for each test case. The line is to contain the score of the test case.

The following shows sample input and output for five test cases.

Sample Input 

5 
OOXXOXXOOO 
OOXXOOXXOO 
OXOXOXOXOXOXOX 
OOOOOOOOOO 
OOOOXOOOOXOOOOX

Sample Output 

10 
9 
7 
55 
30
AC代码:

#include <stdio.h>
#include <string.h>
#define MAXN 85

int main()
{
	int T;
	char s[MAXN];
	scanf("%d", &T);
	while (T--) {
		scanf("%s", s);
		int n = strlen(s);
		// p=0表示上个字符是x
		int score = 0, p = 0, q = 1;
		for (int i = 0; i < n; i++) {
			// 不是很明确字母o是大写还是小写,两种情况都考虑
			if (s[i] == 'o' || s[i] == 'O') {
				if (p == 0) {
					score += q++;
					p = 1;
				}
				else {
					score += q++;
				}
			}
			else {
				p = 0;
				q = 1;
			}
		}
		printf("%d\n", score);
	}

	return 0;
}



转载于:https://www.cnblogs.com/zhangyaoqi/p/4591628.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值