HDU3466 背包DP

Proud Merchants

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 5566    Accepted Submission(s): 2345


Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

 

 

Input
There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

 

 

Output
For each test case, output one integer, indicating maximum value iSea could get.

 

 

Sample Input
2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3
 

 

Sample Output
5
11
 

 

Author
iSea @ WHU
 

 

Source
 
题意:
买一件价格为p的物品时手里的钱不少于q时才能购买。给出n件物品的p,q,v,v代表价值,总钱数m,问最大能够买到多大的价值。
代码:
//先买q大而p小的比较好,所以按照q-p排序,注意是从小到大排序,因为背包公式中
//f[i]=max(f[i],f[i-m]+v)是假设i-m被装满时再装下一件,是假设倒着装的。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int f[5005];
int n,m;
struct proud
{
    int p,q,v,ch;
};
bool cmp(proud a,proud b)
{
    return a.ch<b.ch;
}
/*void zeroonepack(int v,int m,int ttl)
{
    for(int i=ttl;i>=v;i--)
    f[i]=max(f[i],f[i-v]+m);
}
void complitpack(int v,int m,int ttl)
{
    for(int i=v;i<=ttl;i++)
    f[i]=max(f[i],f[i-v]+m);
}
void multipack(int v,int m,int c,int ttl)
{
    if(c*v>=ttl)
    complitpack(v,m,ttl);
    else
    {
        int k=1;
        while(k<c)
        {
            zeroonepack(k*v,k*m,ttl);
            c-=k;
            k*=2;
        }
        zeroonepack(c*v,c*m,ttl);
    }
}*/
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(f,0,sizeof(f));
        proud pr[505];
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d%d",&pr[i].p,&pr[i].q,&pr[i].v);
            pr[i].ch=pr[i].q-pr[i].p;
        }
        sort(pr+1,pr+n+1,cmp);
        for(int i=1;i<=n;i++)
        {
            for(int j=m;j>=pr[i].q;j--)
            {
                f[j]=max(f[j],f[j-pr[i].p]+pr[i].v);
            }
        }
        int ans=0;
        printf("%d\n",f[m]);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/--ZHIYUAN/p/5982485.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值