HDU 2523 SORT AGAIN (hash)

SORT AGAIN

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3092    Accepted Submission(s): 987


Problem Description
给你N个整数,x1,x2...xn,任取两个整数组合得到|xi-xj|,(0<i,j<=N,i!=j)。
现在请你计算第K大的组合数是哪个(一个组合数为第K大是指有K-1个不同的组合数小于它)。
 

 

Input
输入数据首先包含一个正整数C,表示包含C组测试用例.
每组测试数据的第一行包含两个整数N,K。(1<N<=1000,0<K<=2000)
接下去一行包含N个整数,代表x1,x2..xn。(0<=xi<=2000)
 

 

Output
对于每组测试数据,请输出第K大的组合数,每个输出实例占一行。
 

 

Sample Input
3 3 2 4 0 7 4 2 1 2 3 4 2 1 2 9
 

 

Sample Output
4 2 7
 

 

Source
 

 

Recommend
gaojie

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>

using namespace std;

int n,k,num[1010];
int hash[2010];

int abs(int num){
    return num<0?-num:num;
}

int main(){

    //freopen("input.txt","r",stdin);

    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&k);
        for(int i=0;i<n;i++)
            scanf("%d",&num[i]);
        memset(hash,0,sizeof(hash));
        for(int i=0;i<n;i++)
            for(int j=i+1;j<n;j++)
                hash[abs(num[i]-num[j])]++;
        int cnt=0,ans;
        for(int i=0;i<=2000 && cnt<k;i++)
            if(hash[i]){
                cnt++;
                ans=i;
            }
        printf("%d\n",ans);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/jackge/archive/2013/05/23/3094630.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值