HDU 3980 Paint Chain (sg函数)

Paint Chain

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 804    Accepted Submission(s): 292


Problem Description
Aekdycoin and abcdxyzk are playing a game. They get a circle chain with some beads. Initially none of the beads is painted. They take turns to paint the chain. In Each turn one player must paint a unpainted beads. Whoever is unable to paint in his turn lose the game. Aekdycoin will take the first move.

Now, they thought this game is too simple, and they want to change some rules. In each turn one player must select a certain number of consecutive unpainted beads to paint. The other rules is The same as the original. Who will win under the rules ?You may assume that both of them are so clever.
 

 

Input
First line contains T, the number of test cases. Following T line contain 2 integer N, M, indicate the chain has N beads, and each turn one player must paint M consecutive beads. (1 <= N, M <= 1000)
 

 

Output
For each case, print "Case #idx: " first where idx is the case number start from 1, and the name of the winner.
 

 

Sample Input
2 3 1 4 2
 

 

Sample Output
Case #1: aekdycoin Case #2: abcdxyzk
 

 

Author
jayi
 

 

Source

 

题意:有一圈 N 个的硬币, 两个玩家轮流取,每次他们可以取M个连续硬币, 最后一个不能取的为负;

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int N=1010;

int n,m,sg[N];

int mex(int x){
    if(sg[x]!=-1)
        return sg[x];
    int re[N];
    memset(re,0,sizeof(re));
    for(int i=0;i<=x-m-i;i++)
        re[mex(i)^mex(x-m-i)]=1;
    int i=0;
    while(re[i]!=0)
        i++;
    return sg[x]=i;
}

int main(){

    //freopen("input.txt","r",stdin);

    int t,cases=0;
    scanf("%d",&t);
    while(t--){
        memset(sg,-1,sizeof(sg));
        printf("Case #%d: ",++cases);
        scanf("%d%d",&n,&m);
        if(n<m){
            puts("abcdxyzk");
            continue;
        }
        if(m==1){
            if(n&1)
                puts("aekdycoin");
            else
                puts("abcdxyzk");
            continue;
        }
        if(!mex(n-m))
            puts("aekdycoin");
        else
            puts("abcdxyzk");
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/jackge/p/3232616.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值