TOJ-1313 Parallelogram Counting

There are n distinct points in the plane, given by their integer coordinates. Find the number of parallelograms whose vertices lie on these points. In other words, find the number of 4-element subsets of these points that can be written as {A, B, C, D} such that AB || CD, and BC || AD. No four points are in a straight line.

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases. It is followed by the input data for each test case.

The first line of each test case contains an integer n (1 ≤ n ≤ 1000). Each of the next n lines, contains 2 space-separated integers x and y (the coordinates of a point) with magnitude (absolute value) of no more than 1000000000.

Output

Output should contain t lines.
Line i contains an integer showing the number of the parallelograms as described above for test case i.

Sample Input

2
6
0 0
2 0
4 0
1 1
3 1
5 1
7
-2 -1
8 9
5 7
1 1
4 8
2 0
9 8

Sample Output

5
6



Source: Tehran 2004 Iran Nationwide

平行四边形两对角线的中点重合。求平行四边形数即求相等的中点对数。

#include <iostream>
#include <algorithm>
using namespace std;
struct vertice{
    int x,y;
};
vertice p[1010];
vertice q[1000010];
int cmp(vertice a,vertice b)
{
    if(a.x==b.x)
    {
        return a.y<b.y;
    }
    return a.x<b.x;
}
int main(){
    int t,n,i,j;
    cin>>t;
    while(t--){
        cin>>n;
        for(i=0;i<n;i++)
        {
            cin>>p[i].x>>p[i].y;
        }
        int c = 0;
        for(i=0;i<n;i++)
        {
            for(j=i+1;j<n;j++)
            {
                q[c].x=p[i].x+p[j].x;//求中点未除2 
                q[c].y=p[i].y+p[j].y;
                c++;
            }
        }
        sort(q,q+c,cmp);
        long long num = 0;
        long long cnt = 1;
        int x = q[0].x; int y = q[0].y;
        for(i=1;i<c;i++){
            if(q[i].x==x&&q[i].y==y){
                cnt++;
            }
            else{
                x = q[i].x; y = q[i].y;
                num += (cnt-1)*cnt/2;
                cnt = 1;
            }
        }
        if(cnt!=1)
        {
            num += (cnt)*(cnt-1)/2;
        }
        cout<<num<<endl;
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/shenchuguimo/p/6337893.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值