HDU RSA 扩展欧几里得

Problem Description
RSA is one of the most powerful methods to encrypt data. The RSA algorithm is described as follow:

> choose two large prime integer p, q
> calculate n = p × q, calculate F(n) = (p - 1) × (q - 1)
> choose an integer e(1 < e < F(n)), making gcd(e, F(n)) = 1, e will be the public key
> calculate d, making d × e mod F(n) = 1 mod F(n), and d will be the private key

You can encrypt data with this method :

C = E(m) = m e mod n

When you want to decrypt data, use this method :

M = D(c) = c d mod n

Here, c is an integer ASCII value of a letter of cryptograph and m is an integer ASCII value of a letter of plain text.

Now given p, q, e and some cryptograph, your task is to "translate" the cryptograph into plain text.
 

 

Input
Each case will begin with four integers p, q, e, l followed by a line of cryptograph. The integers p, q, e, l will be in the range of 32-bit integer. The cryptograph consists of l integers separated by blanks. 
 

 

Output
For each case, output the plain text in a single line. You may assume that the correct result of plain text are visual ASCII letters, you should output them as visualable letters with no blank between them.
 

 

Sample Input
101 103 7 11 7716 7746 7497 126 8486 4708 7746 623 7298 7357 3239
 

 

Sample Output
I-LOVE-ACM.
 

 

Author
JGShining(极光炫影)
 
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
typedef long long LL;
/*
题目要求
> calculate n = p × q, calculate F(n) = (p - 1) × (q - 1)
> choose an integer e(1 < e < F(n)), making gcd(e, F(n)) = 1, e will be the public key
> calculate d, making d × e mod F(n) = 1 mod F(n), and d will be the private key
知道 P Q E
gcd(a,b) == 1  等价于 存在x,y  a*x+b*y==1
存在x,y 
e*x + F(n)*y = 1 
d*e%F(n) = 1%F(n)
d*e + F(n)*y = 1; 通过求逆元方法解出 d 即可
*/
LL p,q,e,l;
LL ex_gcd(LL a,LL b,LL &x,LL &y)
{
    if(b==0)
    {
        x = 1;
        y = 0;
        return a;
    }
    LL ans = ex_gcd(b,a%b,x,y);
    LL tmp = x;
    x = y;
    y = tmp - a/b*x;
    return ans;
}
LL cal(LL a,LL b,LL c)
{
    LL x=0,y=0;
    LL gcd = ex_gcd(a,b,x,y);
    if(c%gcd!=0) return -1;
    x *= c/gcd;
    b /= gcd;
    if(b<0) b = -b;
    LL ans = x%b;
    if(ans<0) ans+=b;
    return ans;
}
int main()
{
    while(scanf("%lld%lld%lld%lld",&p,&q,&e,&l)!=EOF)
    {
        LL fn = (p-1)*(q-1),n = p*q;
        LL d = cal(e,fn,1);
        LL tmp,ans;
        for(int i=0;i<l;i++)
        {
            scanf("%lld",&tmp);
            tmp %= n;
            ans = 1;
            for(int j=0;j<d;j++)
                ans = (ans*tmp)%n;
            printf("%c",ans%n);
        }
        printf("\n");
    }
}

 

转载于:https://www.cnblogs.com/joeylee97/p/6658240.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值