HDU-1211(RSA)-拓展欧几里得

Problem Description
RSA is one of the most powerful methods to encrypt data. The RSA algorithm is described as follow:

choose two large prime integer p, q
calculate n = p × q, calculate F(n) = (p - 1) × (q - 1)
choose an integer e(1 < e < F(n)), making gcd(e, F(n)) = 1, e will be the public key
calculate d, making d × e mod F(n) = 1 mod F(n), and d will be the private key

You can encrypt data with this method :

C = E(m) = me mod n

When you want to decrypt data, use this method :

M = D(c) = cd mod n

Here, c is an integer ASCII value of a letter of cryptograph and m is an integer ASCII value of a letter of plain text.

Now given p, q, e and some cryptograph, your task is to “translate” the cryptograph into plain text.

Input
Each case will begin with four integers p, q, e, l followed by a line of cryptograph. The integers p, q, e, l will be in the range of 32-bit integer. The cryptograph consists of l integers separated by blanks.

Output
For each case, output the plain text in a single line. You may assume that the correct result of plain text are visual ASCII letters, you should output them as visualable letters with no blank between them.

Sample Input
101 103 7 11
7716 7746 7497 126 8486 4708 7746 623 7298 7357 3239

Sample Output
I-LOVE-ACM.

**RSA是一种密码的加密方式,只要理解本题就可以知道,解密的函数是D(c) = (c^d)%n;需要求的就是d,根据题意我们可以推出d*e - k*fn = 1;
故使用拓展欧几里得可以得打d和k,然后再解密就行了**

完整代码如下:

#include<iostream>
#include<cmath>
#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long int ll;
ll extgcd(ll a,ll b,ll &x,ll &y){
    ll d = a;
    if(b != 0){
        d = extgcd(b,a%b,y,x);
        y -= (a/b)*x;
    }else{
        x = 1;
        y = 0;
    }
    return d;
}
int main(void){
    ll p,q,e,N,a,d,k,n,fn;
    while(cin >> p >> q >> e >> N){//这里必须是多组样例 
        n = p*q;
        fn = (p-1)*(q-1);
        extgcd(e,fn,d,k);
    while(d <= 0)//确保d是大于0的 
        d += fn;
    for(int i=1;i<=N;i++){
        cin >> a;
        ll r = 1;
        for(int i=1;i<=d;i++){
            r *= a;
            r %= n;
        }
        char ch = r;
        cout << ch;
    }
    cout << endl;
}
    return 0;   
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值