hdu 3117 Fibonacci Numbers

Fibonacci Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1766    Accepted Submission(s): 695


Problem Description
The Fibonacci sequence is the sequence of numbers such that every element is equal to the sum of the two previous elements, except for the first two elements f0 and f1 which are respectively zero and one.

What is the numerical value of the nth Fibonacci number?
 

Input
For each test case, a line will contain an integer i between 0 and 10 8 inclusively, for which you must compute the ith Fibonacci number fi. Fibonacci numbers get large pretty quickly, so whenever the answer has more than 8 digits, output only the first and last 4 digits of the answer, separating the two parts with an ellipsis (“...”). 

There is no special way to denote the end of the of the input, simply stop when the standard input terminates (after the EOF).
 

Sample Input
 
   
0 1 2 3 4 5 35 36 37 38 39 40 64 65
 

Sample Output
 
   
0 1 1 2 3 5 9227465 14930352 24157817 39088169 63245986 1023...4155 1061...7723 1716...7565
 

题解及代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#define s_5 sqrt(5.0)
#define sl_5 (0.5+sqrt(5.0)/2.0)
#define sr_5 (0.5-sqrt(5.0)/2.0)
using namespace std;
int fibo[50];
void init()
{
    fibo[0]=0;
    fibo[1]=1;
    int i;
    for(i=2;i<=50;i++)
    {
       fibo[i]=fibo[i-1]+fibo[i-2];
       if(fibo[i]>=100000000)
       {
          break;
       }
    }
}

struct mat
{
    long long  t[2][2];
    void set()
    {
        memset(t,0,sizeof(t));
    }
}a,b;

mat multiple(mat a,mat b,int n,int p)
{
    int i,j,k;
    mat temp;
    temp.set();
    for(i=0;i<n;i++)
    for(j=0;j<n;j++)
    {
        if(a.t[i][j])
        for(k=0;k<n;k++)
            temp.t[i][k]=(temp.t[i][k]+a.t[i][j]*b.t[j][k])%p;
    }
    return temp;
}

mat quick_mod(mat b,int n,int p)
{
    mat t;
    t.t[0][0]=1;
    t.t[0][1]=0;
    t.t[1][0]=0;
    t.t[1][1]=1;
    while(n)
    {
        if(n&1)
        {
           t=multiple(t,b,2,p);
        }
        n>>=1;
        b=multiple(b,b,2,p);
    }
    return t;
}
void init1()
{
    b.t[0][0]=1;
    b.t[0][1]=1;
    b.t[1][0]=1;
    b.t[1][1]=0;
}


int main()
{
    int n;
    init();
    while(cin>>n)
    {
      if(n<40)
      {
          cout<<fibo[n]<<endl;
          continue;
      }
      double s=log10(1.0/s_5)+n*log10(sl_5);
      int len=(int)s+1;
      double t=s-len+4;
      cout<<(int)pow(10.0,t);

      init1();
      a=quick_mod(b,n,10000);
      printf("...%04d\n",a.t[1][0]);
    }
    return 0;
}
/*
一道比較简单的数学题,输出斐波那契数的前四位和后四位。
对于前40项,直接打表输出就能够了。
接下来我们讲一下大于40位的时候怎样计算:

对于后四位,我们能够想到,我们进行滚动数组取余就能求得答案。
可是数据量有点大,这样可定会超时,所以仅仅能使用矩阵高速幂来加速。

对于前四位。我们要使用到斐波那契数的封闭公式:
f[n]=1/sqrt(5)*{[0.5+sqrt(5)/2]^n-[0.5-sqrt(5)/2]^n};
由于n非常大时,[0.5-sqrt(5)/2]^n非常小。差点儿能够忽略。又由于我们计算
的是前四位,所以不必管后面的精度,所以这一项能够省略。
f[n]=1/sqrt(5)*[0.5+sqrt(5)/2]^n;
我们假定t=f[n],k为其前四位,想要求t的前四位数k。我们能够使用科学
计数法来写一下t,t=k.xxxx……*10^(len-4);这里len指的是t的位数。
而计算一个数的位数能够使用log10(t)+1来计算得到。

那么知道了这些就非常好计算了:首先我们先求出t的位数 len=log10(1/sqrt(5)*[0.5+sqrt(5)/2]^n); 化简一下:len=log10(1/sqrt(5))+n*log10(0.5+sqrt(5)/2); 对于t=k.xxxx……*10^(len-4);我们两边进行log10取对数, 得到log10(t)=log10(k.xxxx……)+len-4; 化简一下得到log10(k.xxxx……)=log10(t)-(len-4); 那么我们为了得到k.xxx……,我们能够求10^[log10(t)-(len-4)]即可了。 最后一项,对k取整。

*转载请注明出处,谢谢。 */






转载于:https://www.cnblogs.com/zhchoutai/p/8414058.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值