uva558 Wormholes SPFA 求是否存在负环

J - Wormholes
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF

In the year 2163, wormholes were discovered. A wormhole is a subspace tunnel through space and time connecting two star systems. Wormholes have a few peculiar properties:

  • Wormholes are one-way only.

  • The time it takes to travel through a wormhole is negligible.

  • A wormhole has two end points, each situated in a star system.

  • A star system may have more than one wormhole end point within its boundaries.

  • For some unknown reason, starting from our solar system, it is always possible to end up in any star system by following a sequence of wormholes (maybe Earth is the centre of the universe).

  • Between any pair of star systems, there is at most one wormhole in either direction.

  • There are no wormholes with both end points in the same star system.

All wormholes have a constant time difference between their end points. For example, a specific wormhole may cause the person travelling through it to end up 15 years in the future. Another wormhole may cause the person to end up 42 years in the past.


A brilliant physicist, living on earth, wants to use wormholes to study the Big Bang. Since warp drive has not been invented yet, it is not possible for her to travel from one star system to another one directly. This can be done using wormholes, of course.


The scientist wants to reach a cycle of wormholes somewhere in the universe that causes her to end up in the past. By travelling along this cycle a lot of times, the scientist is able to go back as far in time as necessary to reach the beginning of the universe and see the Big Bang with her own eyes. Write a program to find out whether such a cycle exists.

Input 

The input file starts with a line containing the number of cases  c to be analysed. Each case starts with a line with two numbers  n and  m . These indicate the number of star systems (  $1 \le n \le 1000$) and the number of wormholes (  $0 \le m \le 2000$) . The star systems are numbered from 0 (our solar system) through  n-1 . For each wormhole a line containing three integer numbers  xy and  t is given. These numbers indicate that this wormhole allows someone to travel from the star system numbered  x to the star system numbered  y, thereby ending up  t (  $-1000 \le t \le 1000$) years in the future.

Output 

The output consists of  c lines, one line for each case, containing the word  possible if it is indeed possible to go back in time indefinitely, or  not possible if this is not possible with the given set of star systems and wormholes.

Sample Input 

2
3 3
0 1 1000
1 2 15
2 1 -42
4 4
0 1 10
1 2 20
2 3 30
3 0 -60

Sample Output 

possible
not possible



Miguel A. Revilla
1998-03-10

题意:问能否通过虫洞,回到过去,意思实际上就是求,最短路里面有不有负环。

思路:SPFA 或者Bellman-ford 推断下有不有负环就能够了,对于SPFA,假设有负环,表明进栈次数大于等于n次。


#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#define INF 9999999
using namespace std;

int n,m;
int num[2222];
int dis[2222];
int vis[2222];
int f[2222];
int u[2222],v[2222],w[2222],next[2222];

int spfa()
{
    queue<int>q;
    memset(vis,0,sizeof vis);
    memset(num,0,sizeof num);

    for(int i=0;i<=n;i++) dis[i]=INF;
    dis[0]=0;
    q.push(0);
    num[0]++;

    while(!q.empty())
    {
        int x=q.front(); q.pop();
        vis[x]=0;
        for(int i=f[x];i!=-1;i=next[i])
        if(dis[x]+w[i]<dis[v[i]])
        {
            dis[v[i]]=dis[x]+w[i];
            if(vis[v[i]]==0)
            {
                vis[v[i]]=1;
                q.push(v[i]);
                num[v[i]]++;
                if(num[v[i]]>=n)
                    return 1;
            }
        }
    }

    return 0;
}

int main()
{
    int T;
    scanf("%d",&T);

    while(T--)
    {
        scanf("%d%d",&n,&m);
        memset(f,-1,sizeof f);

        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&u[i],&v[i],&w[i]);
            next[i]=f[u[i]];f[u[i]]=i;
        }

        if(spfa()==0)
            puts("not possible");
        else
            puts("possible");

    }
    return 0;
}

/*
5 4
1 2 1
1 3 2
2 4 3
2 5 2
*/





转载于:https://www.cnblogs.com/zhchoutai/p/6865903.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值