Wormholes - UVa 558 spfa判断负环

76 篇文章 0 订阅

Wormholes

In the year 2163, wormholes were discovered. A wormhole is a subspace tunnel through space and time connecting two star systems. Wormholes have a few peculiar properties:

  • Wormholes are one-way only.

  • The time it takes to travel through a wormhole is negligible.

  • A wormhole has two end points, each situated in a star system.

  • A star system may have more than one wormhole end point within its boundaries.

  • For some unknown reason, starting from our solar system, it is always possible to end up in any star system by following a sequence of wormholes (maybe Earth is the centre of the universe).

  • Between any pair of star systems, there is at most one wormhole in either direction.

  • There are no wormholes with both end points in the same star system.

All wormholes have a constant time difference between their end points. For example, a specific wormhole may cause the person travelling through it to end up 15 years in the future. Another wormhole may cause the person to end up 42 years in the past.


A brilliant physicist, living on earth, wants to use wormholes to study the Big Bang. Since warp drive has not been invented yet, it is not possible for her to travel from one star system to another one directly. This canbe done using wormholes, of course.


The scientist wants to reach a cycle of wormholes somewhere in the universe that causes her to end up in the past. By travelling along this cycle a lot of times, the scientist is able to go back as far in time as necessary to reach the beginning of the universe and see the Big Bang with her own eyes. Write a program to find out whether such a cycle exists.

Input 

The input file starts with a line containing the number of cases  c  to be analysed. Each case starts with a line with two numbers  n  and  m  . These indicate the number of star systems (  $1 \le n \le 1000$ ) and the number of wormholes (  $0 \le m \le 2000$ ) . The star systems are numbered from 0 (our solar system) through  n -1 . For each wormhole a line containing three integer numbers  x y  and  t  is given. These numbers indicate that this wormhole allows someone to travel from the star system numbered  x  to the star system numbered  y , thereby ending up  t  ( $-1000 \le t \le 1000$ ) years in the future.

Output 

The output consists of  c  lines, one line for each case, containing the word  possible  if it is indeed possible to go back in time indefinitely, or  not possible  if this is not possible with the given set of star systems and wormholes.

Sample Input 

2
3 3
0 1 1000
1 2 15
2 1 -42
4 4
0 1 10
1 2 20
2 3 30
3 0 -60

Sample Output 

possible
not possible

题意:给你一些有向边,问是否存在负环。

思路:spfa的bfs判断负环,即一个点被加入队列中的次数超过n次。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
struct node
{
    int v,w,next;
}edge[2010];
int T,t,n,m,H[1010],tot,vis[1010],d[1010],INF=1e9,p[1010];
queue<int> qu;
void AddEdge(int u,int v,int w)
{
    edge[++tot].v=v;
    edge[tot].w=w;
    edge[tot].next=H[u];
    H[u]=tot;
}
void spfa(int s)
{
    int i,j,k,u,v,w;
    qu.push(s);
    memset(vis,0,sizeof(vis));
    memset(p,0,sizeof(p));
    for(i=0;i<n;i++)
       d[i]=INF;
    d[s]=0;vis[s]=1;
    while(!qu.empty())
    {
        u=qu.front();
        qu.pop();
        for(i=H[u];i;i=edge[i].next)
        {
            v=edge[i].v;
            w=edge[i].w;
            if(d[u]+w<d[v])
            {
                d[v]=d[u]+w;
                if(vis[v]==0)
                {
                    qu.push(v);
                    vis[v]=1;
                    if(++p[v]>n)
                    {
                        printf("possible\n");
                        return;
                    }
                }
            }
        }
        vis[u]=0;
    }
    printf("not possible\n");
}
int main()
{
    int i,j,k,u,v,w;
    scanf("%d",&T);
    for(t=1;t<=T;t++)
    {
        scanf("%d%d",&n,&m);
        memset(H,0,sizeof(H));
        tot=0;
        for(i=1;i<=m;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            AddEdge(u,v,w);
        }
        spfa(0);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值