POJ 3281 Dining dinic

Dining
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10445 Accepted: 4805

Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers:  NF, and  D 
Lines 2.. N+1: Each line  i starts with a two integers  Fi and  Di, the number of dishes that cow  i likes and the number of drinks that cow  i likes. The next  Fi integers denote the dishes that cow  i will eat, and the  Di integers following that denote the drinks that cow  i will drink.

Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output

3

Hint

One way to satisfy three cows is: 
Cow 1: no meal 
Cow 2: Food #2, Drink #2 
Cow 3: Food #1, Drink #1 
Cow 4: Food #3, Drink #3 
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.



好久不写网络流了啊啊啊,,差点写挂了hhhh。。


/** Author: ¡î¡¤aosaki(*¡¯(OO)¡¯*)  niconiconi¡ï **/
//#pragma comment(linker, "/STACK:1024000000,1024000000")
//#include<bits/stdc++.h>
#include <iostream>
#include <sstream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <functional>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <list>
#include <stack>
//#include <tuple>
#define ALL(v) (v).begin(),(v).end()
#define foreach(i,v) for (__typeof((v).begin())i=(v).begin();i!=(v).end();i++)
#define SIZE(v) ((int)(v).size())
#define mem(a) memset(a,0,sizeof(a))
#define mem1(a) memset(a,-1,sizeof(a))
#define lp(k,a) for(int k=1;k<=a;k++)
#define lp0(k,a) for(int k=0;k<a;k++)
#define lpn(k,n,a) for(int k=n;k<=a;k++)
#define lpd(k,n,a) for(int k=n;k>=a;k--)
#define sc(a) scanf("%d",&a)
#define sc2(a,b) scanf("%d %d",&a,&b)
#define lowbit(x) (x&(-x))
#define ll long long
#define pi pair<int,int>
#define vi vector<int>
#define PI acos(-1.0)
#define pb(a) push_back(a)
#define mp(a,b) make_pair(a,b)
#define TT cout<<"*****"<<endl;
#define TTT cout<<"********"<<endl;
inline int gcd(int a,int b)
{
    return a==0?b:gcd(b%a,a);
}

#define inf 1e8
#define eps 1e-8
#define mod 10007
#define MAX 10010
#define maxn 1100
using namespace std;

int n,m,tot,S,T,f2,d2;
int head[maxn],cpyh[maxn],q[maxn],d[maxn];

struct edge
{
    int from,to,next,val;
} ji[maxn*maxn];

void add(int x,int y,int w)
{
    ji[tot].from=x;
    ji[tot].to=y;
    ji[tot].val=w;
    ji[tot].next=head[x];
    head[x]=tot++;
    ji[tot].from=y;
    ji[tot].to=x;
    ji[tot].val=0;
    ji[tot].next=head[y];
    head[y]=tot++;
}

int dinic()
{
    int max_flow=0;
    while(1)
    {
        mem1(d);
        int headd=0,tail=0;
        q[tail++]=S;
        d[S]=0;
        while(headd<tail)
        {
            int t=q[headd++];
            for(int k=head[t];k;k=ji[k].next)
            {
                int toit=ji[k].to;
                int val=ji[k].val;
                if(val&&d[toit]==-1)
                {
                    d[toit]=d[t]+1;
                    q[tail++]=toit;
                    if(toit==T)
                    {
                        headd=tail;
                        break;
                    }
                }
            }
        }
        if(d[T]==-1) break;
        memcpy(cpyh,head,(T+1)*sizeof(int));
        for(int i=S,top=0;;)
        {
            if(i==T)
            {
                int flow=inf,st;
                for(int k=0;k<top;k++)
                {
                    if(ji[q[k]].val<flow)
                    {
                        st=k;
                       flow=ji[q[st]].val;
                    }
                }
                for(int k=0;k<top;k++)
                {
                    ji[q[k]].val-=flow;
                    ji[q[k]^1].val+=flow;
                }
                max_flow+=flow;
                top=st;
                i=ji[q[top]].from;
            }
            for(int j=cpyh[i];j;j=cpyh[i]=ji[j].next)
                if(ji[j].val>0&&d[i]+1==d[ji[j].to])
                    break;
            if(cpyh[i])
            {
                q[top++] = cpyh[i];
                i = ji[cpyh[i]].to;
            }
            else
            {
                if(top==0)
                    break;
                d[i]=-1;
                i=ji[q[--top]].from;
            }
        }
    }
    return max_flow;
}


int main()
{
   // freopen("in.txt","r",stdin);
   int nf,nd,x;
    while(~scanf("%d%d%d",&n,&f2,&d2))
    {
        S=0;
        tot=2;
        T=2*n+f2+d2+1;
        mem(head);
        lp(j,n)
        {
            sc(nf); sc(nd);
            lp(i,nf)
            {
                sc(x);
                add(2*n+x,j,1);

            }
            lp(i,nd)
            {
                sc(x);
                add(j+n,2*n+f2+x,1);
            }
            add(j,j+n,1);
        }
        lp(i,f2)
        {
             add(0,2*n+i,1);
        }
        lp(i,d2)
        {
            add(2*n+f2+i,T,1);
        }

        printf("%d\n",dinic());

    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值