hdu acm 1084

贪心题

Problem Description
“Point, point, life of student!”
This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.
Note, only 1 student will get the score 95 when 3 students have solved 4 problems.
I wish you all can pass the exam!
Come on!
 
Input
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0<p.
A test case starting with a negative integer terminates the input and this test case should not to be processed.
 
Output
Output the scores of N students in N lines for each case, and there is a blank line after each case.
 
Sample Input
4
5 06:30:17
4 07:31:27
4 08:12:12
4 05:23:13
1
5 06:30:17
-1
 
Sample Output
100
90
90
95

100

#include "stdio.h"
#include "stdlib.h"
#include "string.h"

typedef struct{
 int s_num;
 int t_num;
 int time;
 int score;
}st;

int cmp_f(const void *a,const void *b)
{
 st *c=(st *)a;
 st *d=(st *)b;
 if(c->t_num==d->t_num)
  return c->time-d->time;
 else
  return d->t_num-c->t_num;
}

int cmp_s(const void *a,const void *b)
{
 st *c=(st *)a;
 st *d=(st *)b;
 return c->s_num-d->s_num;
}

int main()
{
 int n;
 char tp[9];
 int p_num[6];
 st s[120];
 //int tnum;

 while(scanf("%d",&n)==1&&n>=0)
 {
  memset(p_num,0,sizeof(p_num));
  for(int i=0;i<n;i++)
  {
                int hh,mm,ss;
   scanf("%d%s",&s[i].t_num,tp);
   //scanf("%d:%d:%d",&hh,&mm,&ss);
   s[i].s_num=i;

   p_num[s[i].t_num]++;//记录题目数量

   //将时间转化成整数,便于排序
   sscanf(tp,"%d:%d:%d",&hh,&mm,&ss);
   s[i].time=hh*3600+mm*60+ss;
  }

  qsort(s,n,sizeof(st),cmp_f);//将结构体数组按题目数排序

  for(int i=0;i<n;i++)
  {
   if(s[i].t_num==5)
    s[i].score=100;
   else if(s[i].t_num==4)
   {
    if(i+1-p_num[5]<=p_num[4]/2)
     s[i].score=95;
    else
     s[i].score=90;
   }
   else if(s[i].t_num==3)
   {
    if(i+1-p_num[5]-p_num[4]<=p_num[3]/2)
     s[i].score=85;
    else
     s[i].score=80;
   }
   else if(s[i].t_num==2)
   {
    if(i+1-p_num[5]-p_num[4]-p_num[3]<=p_num[2]/2)
     s[i].score=75;
    else
     s[i].score=70;
   }
   else if(s[i].t_num==1)
   {
    if(i+1-p_num[5]-p_num[4]-p_num[3]-p_num[2]<=p_num[1]/2)
     s[i].score=65;
    else
     s[i].score=60;
   }
   else
    s[i].score=50;
  }

  qsort(s,n,sizeof(st),cmp_s);//再将其按序号顺序排回来,以便输出,因为题目的输出是按序号顺序来的

  for(int i=0;i<n;i++)
  {
   printf("%d\n",s[i].score);
  }
  printf("\n");
 }

 return 0;
}

这一题,第一遍就A了,挺有成就感的,嘿嘿~~~

转载于:https://www.cnblogs.com/Shirlies/archive/2012/01/17/2324998.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值